Bug 1470571 - [RFE] Support calling ovirt modules from gdeploy
[RFE] Support calling ovirt modules from gdeploy
Status: CLOSED NOTABUG
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: gdeploy (Show other bugs)
3.3
Unspecified Unspecified
high Severity medium
: ---
: RHGS 3.4.0
Assigned To: Devyani Kota
SATHEESARAN
: FutureFeature
Depends On:
Blocks: 1466132
  Show dependency treegraph
 
Reported: 2017-07-13 04:54 EDT by Sahina Bose
Modified: 2017-11-14 23:56 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-11-14 06:41:41 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sahina Bose 2017-07-13 04:54:56 EDT
Description of problem:

For seamless deployment of Grafton/RHHI, we need to be able to setup the storage domain and add the additional hosts via gdeploy. These can be done through the ansible-ovirt roles that are available. gdeploy needs to be able to integrate with these roles.

Version-Release number of selected component (if applicable):


How reproducible:
NA
Comment 1 Sachidananda Urs 2017-07-27 04:00:23 EDT
What are the usecases? We have to write playbooks to call the roles.
If you already have playbooks which call these roles we can use them. Else we can write our own based on the usecases.
Comment 2 Sahina Bose 2017-07-28 10:16:28 EDT
Usecases would be:
- adding/editing a host.
- editing cluster
- adding storage domain
Comment 4 Devyani Kota 2017-10-17 09:48:17 EDT
@AtinM, yes we are working with the ovirt folks. Should be good for 3.4.0.
Thanks,
Devyani
Comment 6 Sahina Bose 2017-11-14 05:39:40 EST
We had a discussion with oVirt Hosted engine team on the deployment workflow. The HE deployment is now using Ansible playbooks. For the end-to-end deployment which was the goal, the revised flow is:
- pass parameters for creating master storage domain and additional hosts
- use these parameters in a custom playbook that will be used during HE deployment. 
- The playbook will reuse ansible ovirt modules.

In this new flow, there's no requirement for gdeploy to call oVirt modules, and hence this RFE is no longer needed.
Comment 7 Atin Mukherjee 2017-11-14 05:49:24 EST
Can we close this RFE request then?
Comment 8 Sahina Bose 2017-11-14 06:41:41 EST
Yes, closing this not a bug, as this is no longer a requirement

Note You need to log in before you can comment on or make changes to this bug.