Bug 1470583 - Elixir built with wrong endianness
Elixir built with wrong endianness
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: elixir (Show other bugs)
26
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Ricky Elrod
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-13 05:07 EDT by Dag Olav Prestegarden
Modified: 2017-07-31 02:25 EDT (History)
10 users (show)

See Also:
Fixed In Version: elixir-1.4.5-2.fc26
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-31 02:25:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dag Olav Prestegarden 2017-07-13 05:07:48 EDT
User-Agent:       Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/61.0.3153.4 Safari/537.36
Build Identifier: 

Upon starting iex, elixirc, mix or other Elixir software the software crashes with the following message:

warning: Elixir is running in a system with a different endianness than the one its source code was compiled in. Please make sure Elixir and all source files were compiled in a machine with the same endianness as the current one: little

Reproducible: Always

Steps to Reproduce:
1. Install elixir on fedora 26 x86_64 from official repos
2. Run elixirc --version
Actual Results:  
Software crashes with warning messange and crash dump

Expected Results:  
Software running, in this case returning version information.

Package info:
Name        : elixir
Version     : 1.4.2
Release     : 1.fc26

Running Linux 4.11.9-300.fc26.x86_64 #1 SMP Wed Jul 5 16:21:56 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

Worth noting: I observe that the fc26 package is built using a PPC build host buildvm-ppc64-04.ppc.fedoraproject.org while the fc25 package is built using an x86_64 host buildvm-27.phx2.fedoraproject.org
Comment 1 Peter Lemenkov 2017-07-13 05:52:06 EDT
So it turned out that elixir is arch-dependent package. Actually endiannes-dependent but we can build either arch-dependent and arch-independent packages.
Comment 2 Martin Langhoff 2017-07-27 11:07:47 EDT
Looking into this, I'm not sure what the standard practice is to make a package arch-specific. There's been issues in the past with yum and dnf about updates that switch arch.
Comment 3 Fedora Update System 2017-07-27 14:31:47 EDT
elixir-1.4.5-2.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-979f1b8b8b
Comment 4 Fedora Update System 2017-07-28 18:19:43 EDT
elixir-1.4.5-2.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-4d2482da2c
Comment 5 Fedora Update System 2017-07-28 20:53:46 EDT
elixir-1.4.5-2.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-979f1b8b8b
Comment 6 Fedora Update System 2017-07-31 02:25:29 EDT
elixir-1.4.5-2.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.