Bug 1470626 - Need provide icon for 'RED HAT JBOSS' template in catalog-console
Need provide icon for 'RED HAT JBOSS' template in catalog-console
Status: CLOSED ERRATA
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console (Show other bugs)
3.6.0
Unspecified Unspecified
medium Severity low
: ---
: 3.7.0
Assigned To: Steve Speicher
XiaochuanWang
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-13 06:30 EDT by DeShuai Ma
Modified: 2018-01-23 12:57 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-01-23 12:57:29 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
jboss.png (170.14 KB, image/png)
2017-07-13 06:30 EDT, DeShuai Ma
no flags Details

  None (edit)
Description DeShuai Ma 2017-07-13 06:30:30 EDT
Created attachment 1297497 [details]
jboss.png

Description of problem:
Too full screen with 'Red Hat Jboss' words make people crazy, need provide icon.

Version-Release number of selected component (if applicable):
openshift v3.6.143
kubernetes v1.6.1+5115d708d7
etcd 3.2.1

How reproducible:
Always

Steps to Reproduce:
1. Enable catalog-console then login
2. In All tab view scroll to jboss templates
3.

Actual results:


Expected results:


Additional info:
Screenshot will attached
Comment 3 Robb Hamilton 2017-10-30 17:00:45 EDT
PR to resolve: https://github.com/openshift/origin-web-console/pull/2313
Comment 4 Robb Hamilton 2017-10-30 17:06:58 EDT
However, it does not appear the templates have been updated to use the new icons.  
Changing the status back to new and reassigning to Steve Speicher as I believe he is updating the templates.
Comment 5 Steve Speicher 2017-10-30 17:28:02 EDT
1 of 3 PRs have been merged, the 2 remaining are https://github.com/jboss-openshift/application-templates/pull/386 and https://github.com/jboss-openshift/application-templates/pull/389

We are waiting for a xPaaS release to happen to pick this up in the openshift installer. Assign to Rob as think just need his review/signoff.
Comment 6 Rob Cernich 2017-11-10 16:25:10 EST
I assume we're good here, since everything's been merged.
Comment 7 Jessica Forrester 2017-12-14 14:34:37 EST
Sounds like everything made it into 3.7 since all the PRs were merged before november.
Comment 9 yapei 2017-12-17 22:28:26 EST
Now Middleware template are shown with icons based on their Categories in 3.7.14 

Move to VERIFIED
Comment 12 errata-xmlrpc 2018-01-23 12:57:29 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0113

Note You need to log in before you can comment on or make changes to this bug.