Bug 1470640 - Docker stats output shows incorrect MEM USAGE
Docker stats output shows incorrect MEM USAGE
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: docker (Show other bugs)
7.2
x86_64 Linux
unspecified Severity low
: rc
: ---
Assigned To: Antonio Murdaca
atomic-bugs@redhat.com
: Extras
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-13 07:09 EDT by Suhaas Bhat
Modified: 2017-09-05 06:35 EDT (History)
3 users (show)

See Also:
Fixed In Version: docker-2:1.12.6-50.git0fdc778
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-09-05 06:35:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Suhaas Bhat 2017-07-13 07:09:36 EDT
Description of problem:

Output of #docker stats is showing the MEM USAGE combined with the page cache.

Version-Release number of selected component (if applicable):

Red Hat Enterprise Linux 7.2
docker-1.12.6-32.git88a4867.el7.x86_64

How reproducible:

Upstream https://github.com/moby/moby/issues/10824 can be followed for reproducing the issue.

Actual results:

MEM USAGE along with the PAGE CACHE 

Expected results:

Should have displayed the exact MEM USAGE by subtracting the PAGE CACHE

Additional info:
https://github.com/moby/moby/pull/32777 suggests the fix
Comment 2 Antonio Murdaca 2017-07-13 07:18:16 EDT
Backported in 1.12.6, 1.13.1 and 1.13.1-rhel
Comment 3 Suhaas Bhat 2017-07-21 07:09:31 EDT
Can this be of any help ?

https://github.com/docker/cli/pull/80
Comment 5 Luwen Su 2017-08-25 04:38:31 EDT
In docker-1.12.6-55.gitc4618fb.el7.x86_64, it should be the right result

# free -h
              total        used        free      shared  buff/cache   available
Mem:           992M        168M         93M         49M        730M        549M
Swap:          2.0G         35M        2.0G


# docker stats --no-stream e2cdbdad43d3 
CONTAINER           CPU %               MEM USAGE / LIMIT     MEM %               NET I/O             BLOCK I/O           PIDS
e2cdbdad43d3        0.00%               388 KiB / 992.6 MiB   0.04%               1.296 kB / 648 B    90.11 kB / 0 B      1
Comment 7 errata-xmlrpc 2017-09-05 06:35:14 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2599

Note You need to log in before you can comment on or make changes to this bug.