Bug 1470657 - Couchdb installation broken.
Couchdb installation broken.
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: couchdb (Show other bugs)
26
All Linux
unspecified Severity high
: ---
: ---
Assigned To: Peter Lemenkov
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-13 08:11 EDT by Viacheslav Viniarskyi
Modified: 2017-08-04 12:52 EDT (History)
5 users (show)

See Also:
Fixed In Version: couchdb-1.6.1-20.fc26
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-04 12:52:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Viacheslav Viniarskyi 2017-07-13 08:11:26 EDT
Description of problem:
Couchdb installation on fresh fedora 26 installation is broken due to js-1.8.5-27.fc26.x86_64.rpm(dependency) was patched for 48-bit VA (https://fedoraproject.org//wiki/Changes/aarch64-48bitVA). 

Version-Release number of selected component (if applicable):

couchdb-1.6.1-18.fc26.x86_64.rpm
js-1.8.5-27.fc26.x86_64.rpm

How reproducible:


Steps to Reproduce:
1. Install Fedora 26;
2. dnf install couchdb;
3. sudo systemctl start couchdb;
4. run verification http://localhost:5984/_utils/verify_install.html
Actual results:
It says "Running..." freezes and unable to finish verification.

Expected results:
Must complete test, and say "Your installation looks fine. Time to Relax."

Additional info:
In log i say many repeatable messages: " [error] [<0.221.0>] OS Process Error <0.2722.0> :: {os_process_error,         {exit_status,1}}"
Comment 1 Fedora Update System 2017-07-25 13:43:53 EDT
couchdb-1.6.1-20.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-27b0e8f221
Comment 2 Fedora Update System 2017-07-26 22:52:14 EDT
couchdb-1.6.1-20.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-27b0e8f221
Comment 3 Fedora Update System 2017-08-04 12:52:09 EDT
couchdb-1.6.1-20.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.