Bug 1470673 - [abrt] ibus: parse_compose_value(): ibus-engine-simple killed by signal 6
Summary: [abrt] ibus: parse_compose_value(): ibus-engine-simple killed by signal 6
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: ibus
Version: 28
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: fujiwara
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:936229cf4d905bdbc5fe4a48661...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-07-13 12:43 UTC by Agustín Farias
Modified: 2019-02-14 03:11 UTC (History)
7 users (show)

Fixed In Version: ibus-1.5.19-16.fc29 ibus-1.5.19-10.fc28
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-02-14 01:57:59 UTC


Attachments (Terms of Use)
File: backtrace (15.98 KB, text/plain)
2017-07-13 12:43 UTC, Agustín Farias
no flags Details
File: cgroup (289 bytes, text/plain)
2017-07-13 12:43 UTC, Agustín Farias
no flags Details
File: core_backtrace (8.77 KB, text/plain)
2017-07-13 12:43 UTC, Agustín Farias
no flags Details
File: cpuinfo (1.34 KB, text/plain)
2017-07-13 12:44 UTC, Agustín Farias
no flags Details
File: dso_list (2.10 KB, text/plain)
2017-07-13 12:44 UTC, Agustín Farias
no flags Details
File: environ (1.82 KB, text/plain)
2017-07-13 12:44 UTC, Agustín Farias
no flags Details
File: limits (1.29 KB, text/plain)
2017-07-13 12:44 UTC, Agustín Farias
no flags Details
File: maps (10.65 KB, text/plain)
2017-07-13 12:44 UTC, Agustín Farias
no flags Details
File: open_fds (683 bytes, text/plain)
2017-07-13 12:44 UTC, Agustín Farias
no flags Details
File: proc_pid_status (1.26 KB, text/plain)
2017-07-13 12:44 UTC, Agustín Farias
no flags Details
File: var_log_messages (28 bytes, text/plain)
2017-07-13 12:44 UTC, Agustín Farias
no flags Details
The .XCompose file a fedora virtualbox generated by installiere_neo (1.13 MB, text/plain)
2019-01-07 09:37 UTC, har0ke
no flags Details

Description Agustín Farias 2017-07-13 12:43:48 UTC
Version-Release number of selected component:
ibus-1.5.16-2.fc26

Additional info:
reporter:       libreport-2.9.1
backtrace_rating: 4
cmdline:        /usr/libexec/ibus-engine-simple
crash_function: parse_compose_value
executable:     /usr/libexec/ibus-engine-simple
journald_cursor: s=6debf93b4d9849b8b3d352f17259f4e9;i=a75c5;b=3d349cb3c6094211a12ea4de06bfb7d1;m=1c1096d;t=55430ce42d6e6;x=2e30fad3073286ff
kernel:         4.11.9-300.fc26.x86_64
rootdir:        /
runlevel:       N 5
type:           CCpp
uid:            1000

Comment 1 Agustín Farias 2017-07-13 12:43:54 UTC
Created attachment 1297581 [details]
File: backtrace

Comment 2 Agustín Farias 2017-07-13 12:43:56 UTC
Created attachment 1297582 [details]
File: cgroup

Comment 3 Agustín Farias 2017-07-13 12:43:58 UTC
Created attachment 1297583 [details]
File: core_backtrace

Comment 4 Agustín Farias 2017-07-13 12:44:00 UTC
Created attachment 1297584 [details]
File: cpuinfo

Comment 5 Agustín Farias 2017-07-13 12:44:02 UTC
Created attachment 1297585 [details]
File: dso_list

Comment 6 Agustín Farias 2017-07-13 12:44:04 UTC
Created attachment 1297586 [details]
File: environ

Comment 7 Agustín Farias 2017-07-13 12:44:05 UTC
Created attachment 1297587 [details]
File: limits

Comment 8 Agustín Farias 2017-07-13 12:44:07 UTC
Created attachment 1297588 [details]
File: maps

Comment 9 Agustín Farias 2017-07-13 12:44:09 UTC
Created attachment 1297589 [details]
File: open_fds

Comment 10 Agustín Farias 2017-07-13 12:44:11 UTC
Created attachment 1297590 [details]
File: proc_pid_status

Comment 11 Agustín Farias 2017-07-13 12:44:12 UTC
Created attachment 1297591 [details]
File: var_log_messages

Comment 12 fujiwara 2017-07-19 06:58:07 UTC
Your problem is caused by /home/jfarias/.XCompose from your backtrace.
Could you attach the file /home/jfarias/.XCompose ?


(In reply to Agustín Farias from comment #1)
> Created attachment 1297581 [details]
> File: backtrace

#0  __GI_raise (sig=sig@entry=6) at ../sysdeps/unix/sysv/linux/raise.c:51
        set = {__val = {0, 94901597372496, 140735894598256, 94903738636896, 18446603337814953361, 0, 0, 32, 343597383809, 4, 0, 0, 532575944799, 472446402679, 0, 0}}
#1  0x00007fd05d9fe470 in __GI_abort () at abort.c:89
#2  0x00007fd05e02670d in g_assertion_message (domain=domain@entry=0x7fd05e8eb4e6 "IBUS", file=file@entry=0x7fd05e8eb575 "ibuscomposetable.c", line=line@entry=108, func=func@entry=0x7fd05e8eb9f0 <__func__.25674> "parse_compose_value", message=message@entry=0x56507fa0f780 "code should not be reached") at gtestutils.c:2433
#3  0x00007fd05e02679a in g_assertion_message_expr (domain=domain@entry=0x7fd05e8eb4e6 "IBUS", file=file@entry=0x7fd05e8eb575 "ibuscomposetable.c", line=line@entry=108, func=func@entry=0x7fd05e8eb9f0 <__func__.25674> "parse_compose_value", expr=expr@entry=0x0) at gtestutils.c:2456
#4  0x00007fd05e8c59de in parse_compose_value (compose_data=0x56507fa04460, compose_data=0x56507fa04460, line=0x56507fa15630 "<dead_diaeresis> <B> : \"\\\"B\"", val=0x56507fa1c5b0 "\"\\\"B\"") at ibuscomposetable.c:108
#5  parse_compose_line (line=0x56507fa15630 "<dead_diaeresis> <B> : \"\\\"B\"", compose_list=<synthetic pointer>) at ibuscomposetable.c:226
#6  ibus_compose_list_parse_file (compose_file=0x56507fa0f6a0 "/home/jfarias/.XCompose") at ibuscomposetable.c:260

Comment 13 fujiwara 2017-07-24 10:25:09 UTC
Agustín Farias:

Do you have any updates?

Comment 14 Pravin Satpute 2018-03-22 06:22:55 UTC
Since, Reporter has not provided required information. Closing this issue as a insufficient data. 

@Agustín if you can help with required information, we can further work on fixing this issue. Thanks.

Comment 15 har0ke 2019-01-07 09:36:14 UTC
I am having the same issue. I initially came across this error on multiple Ubuntu machines after installing the NEO keyboard layout. Error can be reproduced on a fresh install of fedora 29 (virtualbox) with all updates installed. The NEO keyboard layout install script (https://www.neo-layout.org/installiere_neo) creates the a new .XCompose file that seems to be causing a segfault in ibus-daemon.

The .XCompose contents is mostly generated by neo_compose() in line 3560 (used in line 171)

**
IBUS:ERROR:ibuscomposetable.c:108:parse_compose_value: code should not be reached
**
IBUS:ERROR:engineproxy.c:686:bus_engine_proxy_new_internal: assertion failed (error == NULL): Connection is closed. (g-dbus-error-quark, 0)

Comment 16 har0ke 2019-01-07 09:37:18 UTC
Created attachment 1518933 [details]
The .XCompose file a fedora virtualbox generated by installiere_neo

Comment 17 fujiwara 2019-01-11 03:40:18 UTC
(In reply to har0ke from comment #16)
> Created attachment 1518933 [details]
> The .XCompose file a fedora virtualbox generated by installiere_neo

Thank you. I could reproduce your issue.
I remembered I added the assert for the case I was not sure about to happen really.

Actually your .XCompose has two same sequences:

% grep '<slash> <slash>' .XCompose
<Multi_key> <slash> <slash>      	: "\\"   backslash # REVERSE SOLIDUS
<Multi_key> <slash> <slash>		: "\"	backslash

The first line is correct but the second line is invalid and I added the assert for the wrong syntax.

If you modify your .XCompose, ibus will works fine.

% diff .XCompose.orig .XCompose
6194,6196c6194,6196
< <Multi_key> <slash> <slash>		: "\"	backslash
< <Multi_key> <slash> <less>		: "\"	backslash
< <Multi_key> <less> <slash>		: "\"	backslash
---
> #<Multi_key> <slash> <slash>		: "\"	backslash
> #<Multi_key> <slash> <less>		: "\"	backslash
> #<Multi_key> <less> <slash>		: "\"	backslash

% rm .cache/ibus/compose/*
% ibus exit
% ibus-daemon --xim --verbose &

I will replace the assert with a warning message not to terminate ibus.

Comment 18 fujiwara 2019-01-11 03:49:41 UTC
(In reply to fujiwara from comment #12)
> Your problem is caused by /home/jfarias/.XCompose from your backtrace.
> Could you attach the file /home/jfarias/.XCompose ?
> 
> #4  0x00007fd05e8c59de in parse_compose_value (compose_data=0x56507fa04460,
> compose_data=0x56507fa04460, line=0x56507fa15630 "<dead_diaeresis> <B> :
> \"\\\"B\"", val=0x56507fa1c5b0 "\"\\\"B\"") at ibuscomposetable.c:108

The original issue has that line of:
"<dead_diaeresis> <B> : "\"B"

Currently ibus and gtk supports to output only one char so if \" is appeared, the next char needs to be " otherwise went to assert.

Replacing the assert with a warning also can fix the original issue.

Comment 20 Fedora Update System 2019-01-29 10:14:24 UTC
ibus-1.5.19-13.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2019-3aa0fbffb4

Comment 21 Fedora Update System 2019-01-29 11:09:42 UTC
ibus-1.5.19-10.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2019-8d89d06043

Comment 22 Fedora Update System 2019-01-30 01:58:36 UTC
ibus-1.5.19-13.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-3aa0fbffb4

Comment 23 Fedora Update System 2019-01-30 03:01:20 UTC
ibus-1.5.19-10.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-8d89d06043

Comment 24 Fedora Update System 2019-02-05 12:02:10 UTC
ibus-1.5.19-13.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2019-3aa0fbffb4

Comment 25 Fedora Update System 2019-02-06 04:35:05 UTC
ibus-1.5.19-16.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-3aa0fbffb4

Comment 26 Fedora Update System 2019-02-14 01:57:59 UTC
ibus-1.5.19-16.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.

Comment 27 Fedora Update System 2019-02-14 03:11:14 UTC
ibus-1.5.19-10.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.