Bug 1470675 - [6.2.z][RFE] Clone role from CLI and API
[6.2.z][RFE] Clone role from CLI and API
Status: CLOSED NEXTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Users & Roles (Show other bugs)
6.2.10
Unspecified Unspecified
low Severity medium (vote)
: Unspecified
: --
Assigned To: satellite6-bugs
Katello QA List
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-13 08:47 EDT by Andrii Balakhtar
Modified: 2017-07-18 16:48 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1379985
Environment:
Last Closed: 2017-07-18 16:48:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrii Balakhtar 2017-07-13 08:47:01 EDT
Backport request, 6.2.z is missing cloning role functionality via CLI and API too.

+++ This bug was initially created as a clone of Bug #1379985 +++

Description of problem:
Currently role cannot be cloned from CLI and API,  and can only be cloned from UI. This RFE is to add that support.

Version-Release number of selected component (if applicable):
Satellite 6.3 snap 2

How reproducible:


Steps to Reproduce:
1. Attempt to clone a role from CLI and API
2.
3.

Actual results:
No option to clone a Role from CLI hammer or API.

Expected results:
Support should be added to clone a role from CLI and API.

Additional info:

--- Additional comment from Ondřej Pražák on 2017-01-31 07:18:30 EST ---

Created redmine issue http://projects.theforeman.org/issues/18317 from this bug

--- Additional comment from Ondřej Pražák on 2017-01-31 07:26:00 EST ---

Connecting redmine issue http://projects.theforeman.org/issues/18318 from this bug

--- Additional comment from pm-sat@redhat.com on 2017-03-14 08:04:11 EDT ---

Moving this bug to POST for triage into Satellite 6 since the upstream issue http://projects.theforeman.org/issues/18318 has been resolved.

Note You need to log in before you can comment on or make changes to this bug.