Bug 1470679 - capsule-certs-generate gives incorrect instructions
capsule-certs-generate gives incorrect instructions
Status: CLOSED DUPLICATE of bug 1458749
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Branding (Show other bugs)
Unspecified Unspecified
medium Severity medium (vote)
: Unspecified
: --
Assigned To: satellite6-bugs
Katello QA List
: Triaged
Depends On:
  Show dependency treegraph
Reported: 2017-07-13 08:54 EDT by Peter Ondrejka
Modified: 2017-08-08 04:34 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2017-08-08 04:34:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Peter Ondrejka 2017-07-13 08:54:33 EDT
Description of problem:

The output of successful capsule-cert-genreate:

]# capsule-certs-generate --node-fqdn mycapsule.example.com --certs-tar ~/mycapsule.cexample.com-certs.tar
Installing             Done                                               [100%] [..........................................................]

  To finish the installation, follow these steps:

  If you do not have the smartproxy registered to the Katello instance, then please do the following:

  1. yum -y localinstall http://sathost.example.com/pub/katello-ca-consumer-latest.noarch.rpm
  2. subscription-manager register --org "Default_Organization"

  Once this is completed run the steps below to start the smartproxy installation:

  1. Ensure that the foreman-installer-katello package is installed on the system.
  2. Copy /root/mycapsule.cexample.com-certs.tar to the system sathost.example.com
  3. Run the following commands on the Foreman proxy (possibly with the customized
     parameters, see satellite-installer --scenario foreman-proxy-content --help and
     documentation for more info on setting up additional services):

  satellite-installer --scenario foreman-proxy-content\
                    --foreman-proxy-content-parent-fqdn           "sathost.example.com"\
                    --foreman-proxy-register-in-foreman           "true"\
                    --foreman-proxy-foreman-base-url              "https://sathost.example.com"\
                    --foreman-proxy-trusted-hosts                 "sathost.example.com"\
                    --foreman-proxy-trusted-hosts                 "sathost.example.com"\
                    --foreman-proxy-oauth-consumer-key            "zTxifagZgudLwb9f7GGknmuHMN75pcLH"\
                    --foreman-proxy-oauth-consumer-secret         "LZapwnR4aabmgMPWSNaSBTY6BuPX7fXW"\
                    --foreman-proxy-content-pulp-oauth-secret     "awasWzeYcLTpMesvFUUfeE8gfLzjduUV"\
                    --foreman-proxy-content-certs-tar             "/root/mycapsule.cexample.com-certs.tar"\
                    --puppet-server-foreman-url                   "https://sathost.example.com"
  The full log is at /var/log/foreman-proxy-certs-generate.log

The above looks like a foreman version of the output with smartproxy and Katello references. Step 2 instructs to copy the certs.tar to the satellite server it is already on. Installer options also need review, --scenario foreman-proxy-content would fail with:

ERROR: Selected scenario is DISABLED, can not continue.
       Use --list-scenarios to list available options.
       You can also --enable-scenario SCENARIO to make the selected scenario available.

Version-Release number of selected component (if applicable):

How reproducible:

Actual results:
Incorrect information displayed

Expected results:
Correct instructions
Comment 2 Ivan Necas 2017-08-08 04:34:01 EDT

*** This bug has been marked as a duplicate of bug 1458749 ***

Note You need to log in before you can comment on or make changes to this bug.