Bug 147068 - Can't write to PCI board Serial Port
Summary: Can't write to PCI board Serial Port
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: 3
Hardware: i586
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-02-04 03:40 UTC by Chuck Forsberg
Modified: 2015-01-04 22:16 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-15 21:48:22 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Chuck Forsberg 2005-02-04 03:40:58 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5)
Gecko/20041107 Firefox/1.0

Description of problem:
With a US Robotics Faxmodem 56k model 5610,
attempta by a user process to write to the UART
fail, resulting in an error return.

This problem appeared after the 681 version.
Versions from RH9 to 681 do not have this problem.

Opening the serial port and setting the speed do not
return errors.

The motherboard serial port sends characters normally.

This problem is seen with two 5610 boards.  Both work in
older versions, neither works with versions >681.

p.s.  Opening a serial port whose hardware does not exist
should return an error.  Beyond that, it should not be
possible to set speed on a port that doesn't exist.

caf@omen.com

Version-Release number of selected component (if applicable):
Fedora Core subsequent to 681

How reproducible:
Always

Steps to Reproduce:
1.Install 5610 hardware modem PCI card
2.open port, set speed
3. Write to the port
    

Actual Results:  write error errno=5


Expected Results:  Should send characters to the modem

Additional info:

Comment 1 Dave Jones 2005-07-15 17:46:10 UTC
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.

Comment 2 Chuck Forsberg 2005-07-15 21:48:22 UTC
Not a bug per se.  The new version remapped TTYS4 to TTYS14.
The modem is alive and well at TTYS14.


Note You need to log in before you can comment on or make changes to this bug.