Bug 1470683 - ipmiconsole_setup fails with dracut-fips
ipmiconsole_setup fails with dracut-fips
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: freeipmi (Show other bugs)
7.5-Alt
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Josef Ridky
Rachel Sibley
: Reproducer
Depends On:
Blocks: 1420851 1465925
  Show dependency treegraph
 
Reported: 2017-07-13 08:55 EDT by Filip Krska
Modified: 2017-11-27 15:48 EST (History)
4 users (show)

See Also:
Fixed In Version: freeipmi-1.5.7-1.el7
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-11-27 15:45:53 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Filip Krska 2017-07-13 08:55:31 EDT
Description of problem:

When dracut-fips packages are installed and /etc/system-fips exists

ipmiconsole fails on ipmiconsole_engine_init()

Version-Release number of selected component (if applicable):

freeipmi-1.2.9-8.el7.x86_64

How reproducible:

Always

Steps to Reproduce:

tested on Dell server with IPMI Controller

1. install dracut-fips
2. run

# ipmiconsole -u root -p pwd -h <host>

3.

Actual results:

ipmiconsole_setup: Bad file descriptor

Expected results:

[SOL established]

<host> login: 

[closing the connection]

Additional info:

Affects also conman since it calls the same ipmiconsole_engine_init() library function.
Issue dismisses if you remove /etc/system-fips file.

ipmitool package doesn't suffer the issue

# ipmitool -I lanplus -U root -P pwd -H <host> -e \& sol activate
[SOL Session operational.  Use &? for help]

<host> login: &. [terminated ipmitool]
Comment 1 Filip Krska 2017-07-13 10:55:10 EDT
Interestingly, I didn't manage to reproduce the issue with

freeipmi-1.2.9-3.fc20.x86_64 ... freeipmi-1.5.5-1.fc25.x86_64
Comment 23 Rachel Sibley 2017-11-27 15:48:09 EST
Thanks Josef I ended up closing so that it reflects properly in the queries.

Note You need to log in before you can comment on or make changes to this bug.