Bug 147074 - RFE: Remove old initscripts directories
RFE: Remove old initscripts directories
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: initscripts (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-03 23:26 EST by Mike MacCana
Modified: 2014-03-16 22:52 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-03 23:53:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike MacCana 2005-02-03 23:26:20 EST
Description of problem:
Currently the LSB standard directories /etc/init.d and
/etc/rc(runlevel).d are pointers to the old, Red Hat specific
locations. It might be nice to clean up initscripts for a future
release to remove the old directories, and get service packages to use
the correct locations.
Comment 1 Bill Nottingham 2005-02-03 23:53:18 EST
This is fundamentally impossible in the current RPM context.

What happens is that you have to switch it so that what are currently
directories are symlinks, and the reverse. This is doable, although
very messy since RPM can't atomically replace a directory with a symlink.

But then comes the interesting part. You'll also have the new
package that moves its file from /etc/rc.d/init.d/foo to
/etc/init.d/foo. So, let's follow the state machine for
a package that's upgrade in this manner:

... laying down new files ...
 - OK, I've got a new file /etc/init.d/foo. unlink("/etc/init.d/foo"),
   write new one
... done ...
... removing old files ...
 - OK, I've got the old file /etc/rc.d/init.d/foo. It's not int
   the current package. unlink("/etc/rc.d/init.d/foo")

Oops, that points to the file we just installed. *poof*

Yes, we tried this once for one maddening week. See rawhide.
See rawhide break badly.

Note You need to log in before you can comment on or make changes to this bug.