Bug 147075 - yum trips over desktop-backgrounds
yum trips over desktop-backgrounds
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-03 23:36 EST by Michal Jaegermann
Modified: 2014-01-21 17:51 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-05 15:37:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2005-02-03 23:36:01 EST
Description of problem:

I the current set of rawhide updates yum asked to 'update' or
'upgrade' prints the following:

....
---> Package desktop-backgrounds-basic.noarch 0:2.0-27 set to be updated
....
---> Package desktop-backgrounds-extra.noarch 0:2.0-27 set to be updated
....
--> Running transaction check
--> Processing Conflict: control-center conflicts desktop-backgrounds
< 2.0-27
--> Finished Dependency Resolution
Error: control-center conflicts with desktop-backgrounds < 2.0-27

and we are done.  The only way out I found was to do

   rpm -Fvh --nodeps desktop-backgrounds*.rpm

and after that yum is happy to proceed with a pile of remaining
updates.

There is really no "noarch" package desktop-backgrounds, although
this is a name of the source package for the two above, and
'rpm -qR control-center' does not mention anything of that sort.
Maybe indirectly but 'rpm -q --whatrequires desktop-backgrounds',
also with desktop-backgrounds-base and desktop-backgrounds-extra,
draws blank too.  I am somewhat at loss from where this conflict
is may be coming.

Version-Release number of selected component (if applicable):
yum-2.1.13-1 (rawhide).
Comment 1 Seth Vidal 2005-02-04 01:25:59 EST
desktop-backgrounds-basic provides and unversioned 'desktop-backgrounds'

The interesting part is that rpm is what spits out the conflict report.
So it's  a legit conflict.

my question to you: why is this a yum bug?
It looks like either a package mismatch in rawhide or a packging error.
Comment 2 Jef Spaleta 2005-02-04 01:33:21 EST
>rpm -q --conflicts -p control-center-2.9.4-4.i386.rpm
desktop-backgrounds < 2.0-27

I'm not sure how this is a yum bug.... the control-center package in
the development tree has an explicit conflicts set. Explicit conflicts
do not show up with -R i dont think.

-jef
Comment 3 Michal Jaegermann 2005-02-04 10:44:55 EST
> my question to you: why is this a yum bug?
I do not know that.  I am acting on principle, which long time ago
I was explicitely asked to use, "if you do not know where is the bug
then guess and file against _something_ and developers will sort it
out". :-)

I did not realize that explicitely set conflicts will not show up
with -R and I did not check spec files for packages in question.
Comment 4 Seth Vidal 2005-02-04 10:54:18 EST
rpm -qp --provides
rpm -qp --conflicts
rpm -qp --requires
rpm -qp --obsoletes

these are your friends. :)
Comment 5 Seth Vidal 2005-02-05 15:37:55 EST
closing this as it is not a yum bug
Comment 6 Michal Jaegermann 2005-02-05 16:20:38 EST
So in the interest of a full disclosure whos bug is that yum
gets in a set to be updated desktop-backgrounds 2.0-27 and later
complaints about conflict with desktop-backgrounds < 2.0-27?

'rpm -qRp' is a short form of 'rpm -qp --requires' so I fail
to see how you are breaking any new ground in comment #4. 
Comment 7 Seth Vidal 2005-02-05 16:22:25 EST
The control-center packager already owned up to making a typo mistake
in the conflicts.

it's all straightened out.

Note You need to log in before you can comment on or make changes to this bug.