Bug 1470796 - The scenario tests 'tempest.scenario.test_network_v6.TestGettingAddress' fail
The scenario tests 'tempest.scenario.test_network_v6.TestGettingAddress' fail
Status: CLOSED DUPLICATE of bug 1470784
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-neutron (Show other bugs)
12.0 (Pike)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Assaf Muller
Toni Freger
: AutomationBlocker
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-13 12:55 EDT by Arie Bregman
Modified: 2017-07-20 12:13 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-20 12:13:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Arie Bregman 2017-07-13 12:55:29 EDT
Description of problem:

In latest build (OSP 12, 3 cont, 2 comp, non-containerized) the following tests failed:

*tempest.scenario.test_network_v6.TestGettingAddress.test_multi_prefix_slaac
*tempest.scenario.test_network_v6.TestGettingAddress.test_dualnet_multi_prefix_dhcpv6_stateless

In some builds, one of the tests fails in other both. It's not persistent on a number of tests failing but there is at least one test from "tempest.scenario.test_network_v6.TestGettingAddress" which fails

Version-Release number of selected component (if applicable): openstack-neutrton-11.0.0-0.20170710190714.a51271d.el7ost.noarch


How reproducible: 100%


Steps to Reproduce:
1. Deploy non-containrized HA (3 controllers, 2 compute) deployment 
2. Run neutron API tempest tests

Actual results: test failed with the traceback above


Expected results: test passed successfully


Additional info: non-containerized deployment
Comment 2 Ihar Hrachyshka 2017-07-18 09:36:50 EDT
The tempest traceback:

traceback-1: {{{
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/tempest/lib/common/utils/test_utils.py", line 84, in call_and_ignore_notfound_exc
    return func(*args, **kwargs)
  File "/usr/lib/python2.7/site-packages/tempest/lib/services/network/networks_client.py", line 52, in delete_network
    return self.delete_resource(uri)
  File "/usr/lib/python2.7/site-packages/tempest/lib/services/network/base.py", line 41, in delete_resource
    resp, body = self.delete(req_uri)
  File "/usr/lib/python2.7/site-packages/tempest/lib/common/rest_client.py", line 301, in delete
    return self.request('DELETE', url, extra_headers, headers, body)
  File "/usr/lib/python2.7/site-packages/tempest/lib/common/rest_client.py", line 659, in request
    self._error_checker(resp, resp_body)
  File "/usr/lib/python2.7/site-packages/tempest/lib/common/rest_client.py", line 836, in _error_checker
    message=message)
tempest.lib.exceptions.ServerFault: Got server fault
Details: Unable to find IP address 2003::1:f816:3eff:fe3f:aa00 on subnet 8032a1cd-9236-4126-83fa-2f039ed2b890
}}}

Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/tempest/test.py", line 103, in wrapper
    return f(self, *func_args, **func_kwargs)
  File "/usr/lib/python2.7/site-packages/tempest/scenario/test_network_v6.py", line 252, in test_dualnet_multi_prefix_dhcpv6_stateless
    dualnet=True)
  File "/usr/lib/python2.7/site-packages/tempest/scenario/test_network_v6.py", line 164, in _prepare_and_test
    dualnet=dualnet)
  File "/usr/lib/python2.7/site-packages/tempest/scenario/test_network_v6.py", line 100, in prepare_network
    ipv6_address_mode=address6_mode)
  File "/usr/lib/python2.7/site-packages/tempest/scenario/manager.py", line 766, in _create_subnet
    result = subnets_client.create_subnet(**subnet)
  File "/usr/lib/python2.7/site-packages/tempest/lib/services/network/subnets_client.py", line 27, in create_subnet
    return self.create_resource(uri, post_data)
  File "/usr/lib/python2.7/site-packages/tempest/lib/services/network/base.py", line 61, in create_resource
    resp, body = self.post(req_uri, req_post_data)
  File "/usr/lib/python2.7/site-packages/tempest/lib/common/rest_client.py", line 270, in post
    return self.request('POST', url, extra_headers, headers, body, chunked)
  File "/usr/lib/python2.7/site-packages/tempest/lib/common/rest_client.py", line 659, in request
    self._error_checker(resp, resp_body)
  File "/usr/lib/python2.7/site-packages/tempest/lib/common/rest_client.py", line 836, in _error_checker
    message=message)
tempest.lib.exceptions.ServerFault: Got server fault
Details: Request Failed: internal server error while processing your request.

It seems to happen when a subnet is created. I wonder if this is a duplicate of bug 1470784.
Comment 3 Ihar Hrachyshka 2017-07-18 09:44:21 EDT
Maybe related to https://review.openstack.org/#/c/396718, need to look at when it hit our jobs first.
Comment 4 Assaf Muller 2017-07-20 12:13:37 EDT

*** This bug has been marked as a duplicate of bug 1470784 ***

Note You need to log in before you can comment on or make changes to this bug.