Bug 1470837 - RFE: Bucket Policy compatibility with S3
RFE: Bucket Policy compatibility with S3
Status: CLOSED ERRATA
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: RGW (Show other bugs)
3.0
Unspecified Unspecified
urgent Severity urgent
: rc
: 3.0
Assigned To: Adam C. Emerson
vidushi
Bara Ancincova
: FutureFeature
Depends On:
Blocks: 1494421
  Show dependency treegraph
 
Reported: 2017-07-13 15:01 EDT by Uday Boppana
Modified: 2017-12-05 18:35 EST (History)
13 users (show)

See Also:
Fixed In Version: RHEL: ceph-12.1.4-1.el7cp Ubuntu: ceph_12.1.4-2redhat1xenial
Doc Type: Enhancement
Doc Text:
.Support for S3 Bucket Policy Support for Simple Storage Service (S3) Bucket Policy has been added. Note that the support has the following limitations: * Identity and Access Management (IAM) for users and groups is not supported * String interpolation is not supported * Only a subset of condition keys is supported For details see the https://access.redhat.com/documentation/en-us/red_hat_ceph_storage/3/html-single/developer_guide/#s3-api-bucket-policies[Bucket Policies] section in the Developer Guide for Red{nbsp}Hat Ceph Storage 3.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-12-05 18:35:34 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:3387 normal SHIPPED_LIVE Red Hat Ceph Storage 3.0 bug fix and enhancement update 2017-12-05 22:03:45 EST

  None (edit)
Description Uday Boppana 2017-07-13 15:01:03 EDT
Bucket Policy compatibility with S3
Comment 3 Adam C. Emerson 2017-07-26 11:43:09 EDT
In the long run, yes, we want more S3 compatibility.

What were the specific things of interest right now?
Comment 4 Adam C. Emerson 2017-08-10 11:55:23 EDT
It's a bit ridiculous to mark a feature request as /urgent/ when it contains no actual concrete feature request.
Comment 5 Matt Benjamin (redhat) 2017-08-10 14:46:51 EDT
I feel it needs to be stated clearly:  our RGW policy implementation will never be 100% compatible with AWS/S3.  In some respects we'll be lagging AWS, in other areas an aspect of AWS policy won't be applicable to RGW, and in a few areas we may add policy that is now found in AWS--for example, we're adding 'group' policy which AWS has discussed but has not (yet) implemented.

We should frame the discussion in terms of specific areas in which we want to be compatible.
Comment 6 Gregory Meno 2017-08-14 13:42:03 EDT
What is the next action here? Agree on specific compatibility?
Will we be able to agree on what that is, test that it's so, and make adjustments this week? Who is going to lead this discussion?
Comment 7 Matt Benjamin (redhat) 2017-08-14 14:00:34 EDT
Ah, sorry.  I think this bz is just the RFE for initial bucket policy.  I'll confirm, and maybe re-title this.  

QE already has a list of suppported policy use cases, and shouldn't go outside it.

Matt
Comment 12 Adam C. Emerson 2017-10-23 10:53:53 EDT
I don't know anything about RGW Lifecycle.
Comment 14 Adam C. Emerson 2017-10-24 11:29:15 EDT
What, concretely, do you need info about? I had no involvement in S3 LifeCycle and I'm not competent to say that we support it or don't support it. Also it doesn't belong under a task for bucket policies. There's some stuff related to it in the git log, Abhishek from SuSE apparently worked on it, and Yehudah reverted some version of it.
Comment 19 Adam C. Emerson 2017-10-30 11:48:35 EDT
Doc template filled out.
Comment 22 Adam C. Emerson 2017-11-07 16:11:27 EST
Also, I approve of this doc change!
Comment 25 Kyle Bader 2017-11-15 12:13:05 EST
We only support expiration transitions, we do not support transitions to different storage policies - 

https://bugzilla.redhat.com/show_bug.cgi?id=1421842
Comment 28 errata-xmlrpc 2017-12-05 18:35:34 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:3387

Note You need to log in before you can comment on or make changes to this bug.