Bug 147086 - (ACPI) R51 can't wake up from sleep (display)
(ACPI) R51 can't wake up from sleep (display)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-04 06:05 EST by Colin Charles
Modified: 2015-01-04 17:16 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-16 08:50:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Colin Charles 2005-02-04 06:05:13 EST
Description of problem: My IBM Thinkpad R51, with the latest Fedora kernel
(2.6.10-1.741_FC3) will not wake up from sleep. The system actually wakes up
fine, after s3 sleep, but the display doesn't come back up making the laptop
rather useless


Version-Release number of selected component (if applicable):
2.6.10-1.741_FC3

How reproducible:
100%

Steps to Reproduce:
1. echo 3 > /proc/acpi/sleep
2. Close lid
3. Open lid
  
Actual results:
Display doesn't come back up. Nothing in /var/log/messages gives me anything
useful. I tried waking up the display by pressing the button to wake/dim the
display, and there was a no go 

Expected results:
Wake up from sleep

Additional info: tried to append acpi_sleep=s3_bios during bootup, and nothing
happened

So what I do is I do ctrl+alt+f1, login as root, then reboot. All without seeing
things ;-)

Tried this without ipw2100 loaded as well, and even without X started

00:02.1 Display controller: Intel Corp. 82852/855GM Integrated Graphics Device
(rev 02)

Thats the display adapter from lspci
Comment 1 Colin Charles 2005-04-20 00:14:10 EDT
Appended acpi_sleep=s3_bios to bootup, do echo -n 3 > /proc/acpi/sleep, using
the 2.6.11-1.1240_FC4 kernel from rawhide makes the laptop sleep and wake up
sanely. pm-utils is also installed (pm-utils-0.01-1.i386), so it looks like r51
sleep will work with FC-4

Note You need to log in before you can comment on or make changes to this bug.