Bug 1470909 - anaconda silently crashes with small /, /var, /home, and memory (DOWNLOAD_MPOINTS)
anaconda silently crashes with small /, /var, /home, and memory (DOWNLOAD_MPO...
Status: NEW
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
26
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-13 21:16 EDT by Bruce Jerrick
Modified: 2017-07-13 21:19 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bruce Jerrick 2017-07-13 21:16:49 EDT
Description of problem:
anaconda silently crashes and reboots when installing F26 Release
on a system with a small /, /var, /home, and memory (reasonable
with a separate (large) /usr).  The problem is that none of the
filesystems listed in DOWNLOAD_MPOINTS in dnfpayload.py are large
enough for working space, and /tmp (tmpfs) is also too small due
to the limited memory.  A simple fix is to add "/mnt/sysimage/usr"
to DOWNLOAD_MPOINTS .

Version-Release number of selected component:
anaconda-26.21.11-1.fc26

How reproducible:
100%

Steps to Reproduce:
1. Install F26 Release with something like the following:
    8 GiB     memory (RAM)
    500 MiB   / (root)
    2 GiB     swap
    2 GiB     /var
    27.3 GiB  /usr
    500 MiB   /home
    ~5000 packages, with total size of *.rpm about 4.8 GiB

Actual results:
anaconda silently crashes and reboots shortly into the "Starting
package installation process" stage.

Expected results:
Installation succeeds.

Additional info:
I posted this as Comment 19 to RHBZ #1328151 (now CLOSED ERRATA).
The addition of "/mnt/sysimage/usr" to DOWNLOAD_MPOINTS works, but
using that entails rebuilding the installer with lorax/pungi .
I presume it's too late to change F26, but it would be nice if the
addition could be made in F27 .

Note You need to log in before you can comment on or make changes to this bug.