Bug 1470977 - Screen rotation breaks all video after a few iterations on Tobago PRO [Radeon R7 360 / R9 360 OEM] [1002:665f]
Screen rotation breaks all video after a few iterations on Tobago PRO [Radeon...
Status: CLOSED NEXTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: xorg-x11-drv-ati (Show other bugs)
7.5
x86_64 Linux
unspecified Severity unspecified
: rc
: ---
Assigned To: Lyude
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-14 03:45 EDT by Vasiliy Sharapov
Modified: 2018-02-06 09:47 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-02-06 09:47:30 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vasiliy Sharapov 2017-07-14 03:45:50 EDT
Description of problem:
Changing screen rotation of DP or HDMI output and reverting repeatedly breaks video.

Version-Release number of selected component (if applicable):
RHEL-7.4-20170711.0
xorg-x11-server-Xorg-1.19.3-11.el7.x86_64
xorg-x11-drv-ati-7.7.1-3.20160928git3fc839ff.el7.x86_64
kernel-3.10.0-693.el7.x86_64
linux-firmware-20170606-56.gitc990aae.el7.noarch
mesa-dri-drivers-17.0.1-6.20170307.el7.x86_64

How reproducible:
100% - takes <5 attempts

Steps to Reproduce:
1. Plug in 3 displays - DVI-I, HDMI, and DP (may work with fewer)
2. Open Display settings and pick HDMI or DP
3. Change the rotation of the display
4. Revert to normal rotation
5. GOTO 3

Actual results:
Screens go blank (powered but 100% black), going to VT does nothing (screen turns off to reinitialize but comes back the same). You can run `xrandr -display :0` via ssh - it looks like everything is normal from there. Xorg log looks normal.

Expected results:
Displays work normally even after many configuration changes.

Additional info:
Comment 3 Lyude 2017-08-10 16:41:47 EDT
I think you might need to double check this, I've been trying to reproduce this on the card that you lent me and I've only had one rotation failure (different symptoms then you described) out of probably around 100 tries, and that one just required rerotating the display to fix it. haven't been able to reproduce that one again whatsoever though.
Comment 6 Vasiliy Sharapov 2018-02-06 09:47:30 EST
Cannot reproduce in:

RHEL-7.5-20180205.n.0
xorg-x11-server-Xorg-1.19.5-2.el7.x86_64
xorg-x11-drv-ati-7.10.0-1.el7.x86_64
package amdgpu is not installed
kernel-3.10.0-768.el7.x86_64
kernel-3.10.0-843.el7.x86_64
linux-firmware-20180113-61.git65b1c68.el7.noarch
package mesa is not installed
mesa-dri-drivers-17.2.3-8.20171019.el7.x86_64
package xorg-x11-glamor is not installed
libdrm-2.4.83-2.el7.x86_64

Note You need to log in before you can comment on or make changes to this bug.