Bug 1470980 - Review Request: python-abclient - Python client library for EISOO AnyBackup API
Summary: Review Request: python-abclient - Python client library for EISOO AnyBackup API
Keywords:
Status: ON_QA
Alias: None
Product: Fedora
Classification: Fedora
Component: Package Review
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Matthias Runge
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-07-14 07:55 UTC by Chandan Kumar
Modified: 2017-07-18 02:17 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed:
mrunge: fedora-review+


Attachments (Terms of Use)

Description Chandan Kumar 2017-07-14 07:55:12 UTC
Spec URL: https://chandankumar.fedorapeople.org/python-abclient.spec
SRPM URL: https://chandankumar.fedorapeople.org/python-abclient-0.2.3-1.fc26.src.rpm
Description: Abclient is a python library for EISOO AnyBackup APIs. It is a client 
library for EISOO AnyBackup APIs. It allows openstack karbor to 
create backups for databases and file systems.
Fedora Account System Username: chandankumar
successful Scratch Build: https://koji.fedoraproject.org/koji/taskinfo?taskID=20516105

Comment 1 Jeremy Liu 2017-07-14 08:36:49 UTC
Thank you, Chandan

We need this installed as dependency by OpenStack karbor, and we need this landed
for this patch https://review.openstack.org/#/c/480806/

Comment 2 Matthias Runge 2017-07-14 09:24:25 UTC
Package Review
==============

Legend:
[x] = Pass, [!] = Fail, [-] = Not applicable, [?] = Not evaluated
[ ] = Manual review needed



===== MUST items =====

Generic:
[x]: Package is licensed with an open-source compatible license and meets
     other legal requirements as defined in the legal section of Packaging
     Guidelines.
[x]: License field in the package spec file matches the actual license.
     Note: Checking patched sources after %prep for licenses. Licenses
     found: "Apache (v2.0)", "Unknown or generated", "*No copyright* Apache
     (v2.0)". 2 files have unknown license. Detailed output of licensecheck
     in /home/mrunge/review/1470980-python-abclient/licensecheck.txt
[x]: License file installed when any subpackage combination is installed.
[ ]: Package contains no bundled libraries without FPC exception.
[x]: Changelog in prescribed format.
[x]: Sources contain only permissible code or content.
[-]: Package contains desktop file if it is a GUI application.
[-]: Development files must be in a -devel package
[x]: Package uses nothing in %doc for runtime.
[x]: Package consistently uses macros (instead of hard-coded directory
     names).
[x]: Package is named according to the Package Naming Guidelines.
[x]: Package does not generate any conflict.
[x]: Package obeys FHS, except libexecdir and /usr/target.
[-]: If the package is a rename of another package, proper Obsoletes and
     Provides are present.
[!]: Requires correct, justified where necessary.
[x]: Spec file is legible and written in American English.
[-]: Package contains systemd file(s) if in need.
[x]: Package is not known to require an ExcludeArch tag.
[x]: Large documentation must go in a -doc subpackage. Large could be size
     (~1MB) or number of files.
     Note: Documentation size is 20480 bytes in 2 files.
[x]: Package complies to the Packaging Guidelines
[x]: Package successfully compiles and builds into binary rpms on at least
     one supported primary architecture.
[x]: Package installs properly.
[x]: Rpmlint is run on all rpms the build produces.
     Note: There are rpmlint messages (see attachment).
[x]: If (and only if) the source package includes the text of the
     license(s) in its own file, then that file, containing the text of the
     license(s) for the package is included in %license.
[x]: Package requires other packages for directories it uses.
[x]: Package must own all directories that it creates.
[x]: Package does not own files or directories owned by other packages.
[x]: All build dependencies are listed in BuildRequires, except for any
     that are listed in the exceptions section of Packaging Guidelines.
[x]: Package uses either %{buildroot} or $RPM_BUILD_ROOT
[x]: Package does not run rm -rf %{buildroot} (or $RPM_BUILD_ROOT) at the
     beginning of %install.
[x]: Macros in Summary, %description expandable at SRPM build time.
[x]: Dist tag is present.
[x]: Package does not contain duplicates in %files.
[x]: Permissions on files are set properly.
[x]: Package use %makeinstall only when make install DESTDIR=... doesn't
     work.
[x]: Package is named using only allowed ASCII characters.
[x]: Package does not use a name that already exists.
[x]: Package is not relocatable.
[x]: Sources used to build the package match the upstream source, as
     provided in the spec URL.
[x]: Spec file name must match the spec package %{name}, in the format
     %{name}.spec.
[x]: File names are valid UTF-8.
[x]: Packages must not store files under /srv, /opt or /usr/local

Python:
[x]: Python eggs must not download any dependencies during the build
     process.
[x]: A package which is used by another package via an egg interface should
     provide egg info.
[x]: Package meets the Packaging Guidelines::Python
[x]: Package contains BR: python2-devel or python3-devel
[x]: Binary eggs must be removed in %prep

===== SHOULD items =====

Generic:
[x]: If the source package does not include license text(s) as a separate
     file from upstream, the packager SHOULD query upstream to include it.
[!]: Final provides and requires are sane (see attachments).
[-]: Fully versioned dependency in subpackages if applicable.
     Note: No Requires: %{name}%{?_isa} = %{version}-%{release} in
     python2-abclient , python3-abclient
[?]: Package functions as described.
[x]: Latest version is packaged.
[x]: Package does not include license text files separate from upstream.
[x]: Description and summary sections in the package spec file contains
     translations for supported Non-English languages, if available.
[x]: Package should compile and build into binary rpms on all supported
     architectures.
[-]: %check is present and all tests pass.
[x]: Packages should try to preserve timestamps of original installed
     files.
[x]: Reviewer should test that the package builds in mock.
[x]: Buildroot is not present
[x]: Package has no %clean section with rm -rf %{buildroot} (or
     $RPM_BUILD_ROOT)
[x]: No file requires outside of /etc, /bin, /sbin, /usr/bin, /usr/sbin.
[x]: Packager, Vendor, PreReq, Copyright tags should not be in spec file
[x]: Sources can be downloaded from URI in Source: tag
[x]: SourceX is a working URL.
[x]: Spec use %global instead of %define unless justified.

===== EXTRA items =====

Generic:
[x]: Rpmlint is run on all installed packages.
     Note: There are rpmlint messages (see attachment).
[x]: Spec file according to URL is the same as in SRPM.


Rpmlint
-------
Checking: python2-abclient-0.2.3-1.fc27.noarch.rpm
          python3-abclient-0.2.3-1.fc27.noarch.rpm
          python-abclient-0.2.3-1.fc27.src.rpm
python2-abclient.noarch: W: spelling-error %description -l en_US openstack -> open stack, open-stack, opens tack
python2-abclient.noarch: W: spelling-error %description -l en_US karbor -> arbor, harbor, k arbor
python2-abclient.noarch: W: wrong-file-end-of-line-encoding /usr/share/doc/python2-abclient/README.rst
python3-abclient.noarch: W: spelling-error %description -l en_US openstack -> open stack, open-stack, opens tack
python3-abclient.noarch: W: spelling-error %description -l en_US karbor -> arbor, harbor, k arbor
python3-abclient.noarch: W: wrong-file-end-of-line-encoding /usr/share/doc/python3-abclient/README.rst
python-abclient.src: W: spelling-error %description -l en_US openstack -> open stack, open-stack, opens tack
python-abclient.src: W: spelling-error %description -l en_US karbor -> arbor, harbor, k arbor
3 packages and 0 specfiles checked; 0 errors, 8 warnings.




Rpmlint (installed packages)
----------------------------
python2-abclient.noarch: W: spelling-error %description -l en_US openstack -> open stack, open-stack, opens tack
python2-abclient.noarch: W: spelling-error %description -l en_US karbor -> arbor, harbor, k arbor
python2-abclient.noarch: W: wrong-file-end-of-line-encoding /usr/share/doc/python2-abclient/README.rst
python3-abclient.noarch: W: spelling-error %description -l en_US openstack -> open stack, open-stack, opens tack
python3-abclient.noarch: W: spelling-error %description -l en_US karbor -> arbor, harbor, k arbor
python3-abclient.noarch: W: wrong-file-end-of-line-encoding /usr/share/doc/python3-abclient/README.rst
2 packages and 0 specfiles checked; 0 errors, 6 warnings.



Requires
--------
python2-abclient (rpmlib, GLIBC filtered):
    python(abi)
    python-oslo-log
    python-oslo-utils
    python-requests

python3-abclient (rpmlib, GLIBC filtered):
    python(abi)
    python-oslo-log
    python-oslo-utils
    python-requests



Provides
--------
python2-abclient:
    python-abclient
    python2-abclient
    python2.7dist(abclient)
    python2dist(abclient)

python3-abclient:
    python3-abclient
    python3.6dist(abclient)
    python3dist(abclient)



Source checksums
----------------
https://files.pythonhosted.org/packages/source/a/abclient/abclient-0.2.3.tar.gz :
  CHECKSUM(SHA256) this package     : ecfe6841e666a7c7e2ae6382d4ff537f808a5cf52366659e6e0a0bcf2bfd49a7
  CHECKSUM(SHA256) upstream package : ecfe6841e666a7c7e2ae6382d4ff537f808a5cf52366659e6e0a0bcf2bfd49a7


Generated by fedora-review 0.6.1 (f03e4e7) last change: 2016-05-02
Command line :/usr/bin/fedora-review -b 1470980
Buildroot used: fedora-rawhide-x86_64
Active plugins: Python, Generic, Shell-api
Disabled plugins: Java, C/C++, fonts, SugarActivity, Ocaml, Perl, Haskell, R, PHP, Ruby
Disabled flags: EXARCH, DISTTAG, EPEL5, BATCH, EPEL6




One issue: py3 package requires python2 dependencies. Everything else looks fine.

Comment 3 Chandan Kumar 2017-07-14 09:35:49 UTC
Hello Matthias,

Thanks for the review.
Here is the updated
SPEC: https://chandankumar.fedorapeople.org/python-abclient.spec
SRPM: https://chandankumar.fedorapeople.org/python-abclient-0.2.3-2.fc26.src.rpm
Koji Build: https://koji.fedoraproject.org/koji/taskinfo?taskID=20517592

Thanks,

Chandan Kumar

Comment 4 Matthias Runge 2017-07-14 09:37:39 UTC
looks good now, approved.

Comment 5 Gwyn Ciesla 2017-07-14 12:51:11 UTC
Package request has been approved: https://admin.fedoraproject.org/pkgdb/package/rpms/python-abclient

Comment 6 Fedora Update System 2017-07-17 06:10:01 UTC
python-abclient-0.2.3-2.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-fce8843d41

Comment 7 Fedora Update System 2017-07-17 06:30:23 UTC
python-abclient-0.2.3-4.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-d61e2e47b5

Comment 8 Fedora Update System 2017-07-18 00:24:02 UTC
python-abclient-0.2.3-2.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-fce8843d41

Comment 9 Fedora Update System 2017-07-18 02:17:41 UTC
python-abclient-0.2.3-4.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-d61e2e47b5


Note You need to log in before you can comment on or make changes to this bug.