Bug 1470987 - discovery settings are named differently in hammer than in UI
discovery settings are named differently in hammer than in UI
Status: NEW
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Hammer (Show other bugs)
6.3.0
Unspecified Unspecified
medium Severity medium (vote)
: Unspecified
: --
Assigned To: satellite6-bugs
Katello QA List
http://projects.theforeman.org/issues...
: Reopened, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-14 04:32 EDT by Sachin Ghai
Modified: 2018-06-10 01:27 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-20 05:02:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 20360 None None None 2017-07-20 09:06 EDT

  None (edit)
Description Sachin Ghai 2017-07-14 04:32:26 EDT
Description of problem: 

In 6.3 snap6 UI, I see following two settings:

1. Hostname_facts
2. Hostname_prefix

However, in CLI hammer same settings are named as:

1. discovery_hostname
2. discovery_prefix


I think all settings names in hammer should be consistent w/ UI

Version-Release number of selected component (if applicable):
sat6.3 snap6

How reproducible:
always

Steps to Reproduce:
1.  hammer settings list | grep discovery
2.
3.

Actual results:
mismatch in discovery settings names in UI and hammer

Expected results:
for consistency, name should be same at both places ( UI and CLI)

Additional info:
Comment 3 Sachin Ghai 2017-07-20 04:34:47 EDT
I would prefer to have the fix in 6.3 only. This may create a usability issue as same settings are named differently at UI and CLI.
Comment 11 pm-sat@redhat.com 2017-07-20 10:15:58 EDT
Upstream bug assigned to orabin@redhat.com
Comment 12 Sachin Ghai 2017-08-08 04:13:49 EDT
@Brad, I would like to stick w/ the bz.
Comment 13 Lukas Zapletal 2018-05-29 10:21:35 EDT
After another look, I believe this should be fixed in hammer core.

Note You need to log in before you can comment on or make changes to this bug.