Bug 1471026 - hosted-engine-setup does not store nfs_version
hosted-engine-setup does not store nfs_version
Status: CLOSED DUPLICATE of bug 1359265
Product: ovirt-hosted-engine-setup
Classification: oVirt
Component: Plugins.NFS (Show other bugs)
2.1.3
All Linux
unspecified Severity high (vote)
: ---
: ---
Assigned To: Simone Tiraboschi
meital avital
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-14 05:37 EDT by Hesham
Modified: 2017-07-17 05:21 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-17 05:21:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Integration
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hesham 2017-07-14 05:37:22 EDT
Deploying hosted engine on an NFSv4 storage and selecting nfsv4 during the installation completes the installation correctly for the first host, however the nfs_version for the hosted_engine storage is not saved in the storage_server_connections table on the engine and instead is left blank. This causes any new host to use nfsvers=3 mount option when trying to mount hosted_storage causing nfsv4 only setups to fail.

To reproduce just install hosted engine on nfsv4 server and select nfsv4 during deploy and check storage_server_connections.nfs_version, it would be blank instead of saving the correct version.
Comment 1 Yaniv Lavi 2017-07-17 05:21:14 EDT

*** This bug has been marked as a duplicate of bug 1359265 ***

Note You need to log in before you can comment on or make changes to this bug.