Bug 1471032 - Synaptics s3203 touchpad not working after resume from suspend
Synaptics s3203 touchpad not working after resume from suspend
Status: CLOSED DUPLICATE of bug 1442699
Product: Fedora
Classification: Fedora
Component: libinput (Show other bugs)
26
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Peter Hutterer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-14 05:47 EDT by Rodd Clarkson
Modified: 2017-07-17 23:13 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-17 23:13:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rodd Clarkson 2017-07-14 05:47:17 EDT
Description of problem:

With the update to F26, my synaptics touchpad  on my Dell XPS 13 9333 no longer works after resuming from a suspended state.

libinput-list-devices shows this:

<snip>

Device:           Synaptics s3203
Kernel:           /dev/input/event15
Group:            8
Seat:             seat0, default
Size:             97x59mm
Capabilities:     pointer 
Tap-to-click:     disabled
Tap-and-drag:     enabled
Tap drag lock:    disabled
Left-handed:      disabled
Nat.scrolling:    disabled
Middle emulation: disabled
Calibration:      n/a
Scroll methods:   *two-finger edge 
Click methods:    *button-areas clickfinger 
Disable-w-typing: enabled
Accel profiles:   none
Rotation:         n/a

<snip>

and evtest allows me to pick 15, which then spews out input as you interact with the touchpad before a suspend, but doesn't after a suspend.


Version-Release number of selected component (if applicable):

$ rpm -q libinput xorg-x11-drv-libinput
libinput-1.7.3-1.fc26.x86_64
xorg-x11-drv-libinput-0.25.1-2.fc26.x86_64


How reproducible:

Every time.

Steps to Reproduce:
1. Start the system and use the trackpad
2. Suspend and resume
3. Trackpad no longer works.


Additional info:

My synaptics based touchscreen works fine.
Comment 1 Peter Hutterer 2017-07-17 23:13:38 EDT

*** This bug has been marked as a duplicate of bug 1442699 ***

Note You need to log in before you can comment on or make changes to this bug.