Bug 1471082 - FinishedActivating notification is shown before host is actually activated
FinishedActivating notification is shown before host is actually activated
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin (Show other bugs)
4.2.0
All All
unspecified Severity medium (vote)
: ovirt-4.2.0
: 4.2.0
Assigned To: Ravi Nori
Lucie Leistnerova
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-14 07:26 EDT by Radim Hrazdil
Modified: 2017-12-20 06:32 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-12-20 06:32:14 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑4.2+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 82714 master MERGED engine: FinishedActivating notification is shown before host is actually activated 2017-10-19 03:54 EDT

  None (edit)
Description Radim Hrazdil 2017-07-14 07:26:57 EDT
Description of problem:
When activating host from maintenance mode, the green FinishedActivating notification is shown right after clicking Activate button, but the host is still in Activating state. 

Version-Release number of selected component (if applicable):
oVirt Engine Version: 4.2.0-0.0.master.20170712143425.gitcb02bb5.el7.centos

How reproducible:
100%

Steps to Reproduce:
1. Activate host from maintenance

Actual results:
Notification saying that the host has been activated is shown, but the host is still in Activating state.

Expected results:
Notification should be displayed only after the host changes status from Activating to Up. 

Additional info:
Comment 1 Oved Ourfali 2017-07-15 05:56:31 EDT
This is actually a bug on the infra side, as the host activation initiation was completed, but it is not active yet. 

Martin, shall we change the message?
Comment 2 Lucie Leistnerova 2017-10-31 08:42:22 EDT
First the 'Finished Invoking Activate' notice appears and 'Finished Activating' notice appears when the host is really up.

verified in ovirt-engine-webadmin-portal-4.2.0-0.0.master.20171030210714.gitef6bb9c.el7.centos.noarch
Comment 3 Sandro Bonazzola 2017-12-20 06:32:14 EST
This bugzilla is included in oVirt 4.2.0 release, published on Dec 20th 2017.

Since the problem described in this bug report should be
resolved in oVirt 4.2.0 release, published on Dec 20th 2017, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.

Note You need to log in before you can comment on or make changes to this bug.