Bug 1471106 - [patch] enable nginx http_auth_request_module
[patch] enable nginx http_auth_request_module
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: nginx (Show other bugs)
27
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jamie Nguyen
Fedora Extras Quality Assurance
:
: 1372621 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-14 08:36 EDT by Tim Niemueller
Modified: 2017-08-23 20:54 EDT (History)
11 users (show)

See Also:
Fixed In Version: nginx-1.12.1-1.fc25 nginx-1.12.1-1.fc26
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-23 15:54:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to enable module in Fedora package (1.16 KB, application/mbox)
2017-07-14 08:36 EDT, Tim Niemueller
no flags Details

  None (edit)
Description Tim Niemueller 2017-07-14 08:36:19 EDT
Created attachment 1298301 [details]
Patch to enable module in Fedora package

Description of problem:
The current nginx package does not enable the http_auth_request module. However, this can be very useful. It is enabled by default for example in the official nginx docker images or on Ubuntu. We have used it in production and it works reliably and stable.

The attached patch can be applied to the Fedora package repository. It would be nice to backport this to F26 and F25.
Comment 1 Tim Niemueller 2017-08-15 03:57:31 EDT
Any opinion?
Comment 2 Tim Niemueller 2017-08-15 04:01:39 EDT
*** Bug 1372621 has been marked as a duplicate of this bug. ***
Comment 4 Jan Kurik 2017-08-15 04:14:10 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 27 development cycle.
Changing version to '27'.
Comment 5 Joe Orton 2017-08-15 04:25:26 EDT
Thanks for the patch, Tim!
Comment 6 Joe Orton 2017-08-15 04:31:40 EDT
Package: nginx-1.12.1-1.fc27
Build: https://koji.fedoraproject.org/koji/buildinfo?buildID=955507
Comment 7 Tim Niemueller 2017-08-15 04:33:57 EDT
Hi Joe. Thanks for picking up on this!

Would you mind taking a look at the el6 and epel7 tickets (#1471108 and #1471107 respectively)?
Comment 8 Joe Orton 2017-08-15 04:47:34 EDT
Looks fine to merge epel7 to master, though the el6 branch looks out of date. I've no plans to maintain nginx in EPEL myself, feel free to take it on!
Comment 9 Joe Orton 2017-08-15 04:56:51 EDT
Package: nginx-1.12.1-1.fc26
Build: https://koji.fedoraproject.org/koji/buildinfo?buildID=955510
Comment 10 Joe Orton 2017-08-15 04:58:18 EDT
Package: nginx-1.12.1-1.fc25
Build: https://koji.fedoraproject.org/koji/buildinfo?buildID=955511
Comment 11 Fedora Update System 2017-08-15 05:18:24 EDT
nginx-1.12.1-1.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-c27a947af1
Comment 12 Fedora Update System 2017-08-15 18:21:34 EDT
nginx-1.12.1-1.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-c27a947af1
Comment 13 Fedora Update System 2017-08-15 20:53:36 EDT
nginx-1.12.1-1.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-aecd25b8a9
Comment 14 Fedora Update System 2017-08-23 15:54:08 EDT
nginx-1.12.1-1.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.
Comment 15 Fedora Update System 2017-08-23 20:54:32 EDT
nginx-1.12.1-1.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.