Bug 147113 - stardict segfaulting on x86_64
stardict segfaulting on x86_64
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: stardict (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Leon Ho
:
Depends On:
Blocks: FC4Target
  Show dependency treegraph
 
Reported: 2005-02-04 09:32 EST by Jens Petersen
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-19 22:42:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jens Petersen 2005-02-04 09:32:42 EST
Description of problem:
stardict.x86_64 doesn't seem to work well.
For quite a few of the dictionary packages available
from the SF project page it segfaults, and even for
those that it doesn't, searching presents no entries.

Version-Release number of selected component (if applicable):
stardict-2.4.4-1.x86_64

How reproducible:
every time

Steps to Reproduce:
1. install ja quick dictionaries
2. install instead jmdict's
  
Actual results:
1. segfaults
2. Lots of:
(stardict:17727): Pango-WARNING **: Invalid UTF-8 string passed to
pango_layout_set_text()

Expected results:
Not errors.

Additional info:
i386 seems to be ok.
Comment 3 Evgeniy 2005-06-24 12:24:51 EDT
(In reply to comment #0)
> Description of problem:
> stardict.x86_64 doesn't seem to work well.
> For quite a few of the dictionary packages available
> from the SF project page it segfaults, and even for
> those that it doesn't, searching presents no entries.
> 
> Version-Release number of selected component (if applicable):
> stardict-2.4.4-1.x86_64
> 
> How reproducible:
> every time
> 
> Steps to Reproduce:
> 1. install ja quick dictionaries
> 2. install instead jmdict's
>   
> Actual results:
> 1. segfaults
> 2. Lots of:
> (stardict:17727): Pango-WARNING **: Invalid UTF-8 string passed to
> pango_layout_set_text()
> 
> Expected results:
> Not errors.
> 
> Additional info:
> i386 seems to be ok.

it is because of stardict suppose that sizeof(glong)==4 on all platforms
Comment 4 Evgeniy 2005-09-18 15:02:06 EDT
This bug was fixed in stardict 2.4.5, may be just make version bump?
Comment 5 Leon Ho 2005-09-18 21:30:18 EDT
Thanks. 2.4.5 has built in rawhide now
Comment 6 Jens Petersen 2005-09-19 22:42:00 EDT
Thanks, indeed stardict-2.4.5 fixes the problem for me.

Note You need to log in before you can comment on or make changes to this bug.