This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1471258 - Add emacs build with LUCID X toolkit
Add emacs build with LUCID X toolkit
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: emacs (Show other bugs)
26
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Jan Synacek
Fedora Extras Quality Assurance
: Reopened
Depends On: 1470692
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-14 16:21 EDT by Gregory Shimansky
Modified: 2017-08-01 17:56 EDT (History)
6 users (show)

See Also:
Fixed In Version: emacs-25.2-3.fc26 emacs-25.2-3.fc25
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-01 17:56:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch for LUCID toolkit support (4.88 KB, application/mbox)
2017-07-14 16:21 EDT, Gregory Shimansky
no flags Details

  None (edit)
Description Gregory Shimansky 2017-07-14 16:21:57 EDT
Created attachment 1298624 [details]
Patch for LUCID toolkit support

Description of problem:

Emacs warns that there is a bug in GTK which crashes Emacs when X display is disconnected:

When compiled with GTK, Emacs cannot recover from X disconnects.
This is a GTK bug: https://bugzilla.gnome.org/show_bug.cgi?id=85715

This bug has been open since year 2002, and will probably exist for some more time. For this reason Ubuntu has a -lucid version of Emacs package. Fedora for some reason doesn't have one. Also some people may prefer LUCID look and feel to one that GTK version provides. For example when using current Cygwin X11 server, I cannot see GTK menus while LUCID menus work well.

I attached a patch which adds -lucid build for Emacs package. I used it for a while and found no bugs.

Version-Release number of selected component (if applicable):
25.2


How reproducible:



Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Jan Synacek 2017-07-17 03:48:27 EDT
Thanks, I'll take a look and test this a bit first.
Comment 2 Jan Synacek 2017-07-18 03:00:39 EDT
The package is built for F26, you can find it at https://koji.fedoraproject.org/koji/buildinfo?buildID=919405. I can't create an update yet, because I still haven't built it for rawhide due to some compilation failures. Feel free to let me know if the F26 package works for you.
Comment 3 Jan Synacek 2017-07-18 06:09:10 EDT
The build failures are tracked in https://bugzilla.redhat.com/show_bug.cgi?id=1470692.
Comment 4 Fedora Update System 2017-07-20 07:32:31 EDT
emacs-25.2-3.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-65a320831f
Comment 5 Fedora Update System 2017-07-20 21:22:57 EDT
emacs-25.2-3.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-65a320831f
Comment 6 Fedora Update System 2017-07-22 23:58:11 EDT
emacs-25.2-3.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.
Comment 7 JM 2017-07-27 05:52:31 EDT
Any chance to get this version of emacs for Fedora 25 as well?
Comment 9 JM 2017-07-27 10:01:09 EDT
Great, thank you.
Comment 10 Fedora Update System 2017-07-28 18:19:30 EDT
emacs-25.2-3.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-f5ef3fa669
Comment 11 Fedora Update System 2017-08-01 17:56:03 EDT
emacs-25.2-3.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.