Bug 1471293 - Libreoffice coredumps on start
Libreoffice coredumps on start
Status: CLOSED DUPLICATE of bug 1468436
Product: Fedora
Classification: Fedora
Component: libreoffice (Show other bugs)
26
i686 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-14 18:18 EDT by Veteran
Modified: 2017-12-24 04:35 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-12-05 11:46:56 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Veteran 2017-07-14 18:18:07 EDT
Description of problem:
New upgrade of Fedora 26. I start Libreoffice, splash screen loads and then quits. When I attempt to start from command line I get the message:

$ libreoffice

** (soffice:31967): WARNING **: Couldn't connect to accessibility bus: Failed to connect to socket /tmp/dbus-PWekjtHyG8: Connection refused


Version-Release number of selected component (if applicable):
$ uname -a
Linux milano.local 4.11.9-300.fc26.i686 #1 SMP Wed Jul 5 17:01:19 UTC 2017 i686 i686 i386 GNU/Linux

$ rpm -qa |grep libreoffice
libreoffice-ure-5.3.4.2-2.fc26.i686
libreoffice-impress-5.3.4.2-2.fc26.i686
libreoffice-pdfimport-5.3.4.2-2.fc26.i686
libreoffice-base-5.3.4.2-2.fc26.i686
libreoffice-graphicfilter-5.3.4.2-2.fc26.i686
libreoffice-writer-5.3.4.2-2.fc26.i686
libreoffice-core-5.3.4.2-2.fc26.i686
libreoffice-calc-5.3.4.2-2.fc26.i686
libreoffice-ure-common-5.3.4.2-2.fc26.noarch
libreoffice-langpack-en-5.3.4.2-2.fc26.i686
libreoffice-gtk2-5.3.4.2-2.fc26.i686
libreoffice-emailmerge-5.3.4.2-2.fc26.i686
libreoffice-x11-5.3.4.2-2.fc26.i686
libreoffice-pyuno-5.3.4.2-2.fc26.i686
libreoffice-draw-5.3.4.2-2.fc26.i686
libreoffice-opensymbol-fonts-5.3.4.2-2.fc26.noarch
libreoffice-writer2xhtml-1.0.2-20.fc26.i686
libreoffice-gtk3-5.3.4.2-2.fc26.i686
libreoffice-data-5.3.4.2-2.fc26.noarch
libreoffice-math-5.3.4.2-2.fc26.i686


How reproducible:
Everytime

Steps to Reproduce:
1. Open a terminal
2. Type libreoffice
3. Press enter

Actual results:
$ libreoffice

** (soffice:31967): WARNING **: Couldn't connect to accessibility bus: Failed to connect to socket /tmp/dbus-PWekjtHyG8: Connection refused


Expected results:
Start libreoffice

Additional info:

$ sudo coredumpctl
TIME                            PID   UID   GID SIG COREFILE  EXE
Fri 2017-07-14 18:02:45 EDT   31554  1000  1000  11 present   /usr/lib/libreoffice/program/soffice.bin
Fri 2017-07-14 18:03:24 EDT   31593  1000  1000  11 present   /usr/lib/libreoffice/program/soffice.bin
Fri 2017-07-14 18:03:35 EDT   31622  1000  1000  11 present   /usr/lib/libreoffice/program/soffice.bin
Fri 2017-07-14 18:03:50 EDT   31658  1000  1000  11 present   /usr/lib/libreoffice/program/soffice.bin
Fri 2017-07-14 18:06:50 EDT   31824  1000  1000  11 present   /usr/lib/libreoffice/program/soffice.bin
Comment 1 Veteran 2017-07-14 18:21:12 EDT
Also creates this in /tmp and doesn't remove when quits

srwxrwxr-x. 1 lelia lelia unconfined_u:object_r:user_tmp_t:s0  0 Jul 14 18:20 OSL_PIPE_1000_SingleOfficeIPC_2143264fd09ed9fb97ac1b681dd66bdf
Comment 2 Veteran 2017-07-14 18:40:33 EDT
There was a new libreoffice in testing repo so I tried that. Same outcome as above:

$ libreoffice

** (soffice:496): WARNING **: Couldn't connect to accessibility bus: Failed to connect to socket /tmp/dbus-PWekjtHyG8: Connection refused

$ rpm -qa|grep libreoffice
libreoffice-emailmerge-5.3.4.2-3.fc26.i686
libreoffice-ure-common-5.3.4.2-3.fc26.noarch
libreoffice-opensymbol-fonts-5.3.4.2-3.fc26.noarch
libreoffice-gtk2-5.3.4.2-3.fc26.i686
libreoffice-calc-5.3.4.2-3.fc26.i686
libreoffice-core-5.3.4.2-3.fc26.i686
libreoffice-pdfimport-5.3.4.2-3.fc26.i686
libreoffice-pyuno-5.3.4.2-3.fc26.i686
libreoffice-data-5.3.4.2-3.fc26.noarch
libreoffice-draw-5.3.4.2-3.fc26.i686
libreoffice-graphicfilter-5.3.4.2-3.fc26.i686
libreoffice-gtk3-5.3.4.2-3.fc26.i686
libreoffice-math-5.3.4.2-3.fc26.i686
libreoffice-impress-5.3.4.2-3.fc26.i686
libreoffice-langpack-en-5.3.4.2-3.fc26.i686
libreoffice-ure-5.3.4.2-3.fc26.i686
libreoffice-writer2xhtml-1.0.2-20.fc26.i686
libreoffice-writer-5.3.4.2-3.fc26.i686
libreoffice-x11-5.3.4.2-3.fc26.i686
libreoffice-base-5.3.4.2-3.fc26.i686
Comment 3 Veteran 2017-07-15 20:24:29 EDT
Performed upgrade on x86_64 laptop and libreoffice works correctly there
Comment 4 Caolan McNamara 2017-07-17 16:08:27 EDT
I wonder if its the i686 java jvm vs recent kernel problem
Comment 5 Veteran 2017-07-19 00:00:19 EDT
These are the versions
[lelia@milano ~]$ rpm -qa|grep openjdk
java-1.8.0-openjdk-devel-1.8.0.131-7.b12.fc26.i686
java-1.8.0-openjdk-1.8.0.131-7.b12.fc26.i686
java-1.8.0-openjdk-headless-1.8.0.131-7.b12.fc26.i686

[lelia@milano ~]$ rpm -q kernel
kernel-4.11.9-200.fc25.i686
kernel-4.11.9-300.fc26.i686
kernel-4.11.10-300.fc26.i686

I updated the kernel tonight and it is still dying.

I would troubleshoot more but I don't know where to look.

I did create a new i686 vm just to acertain that it wasn't built up junk (this one has been upgraded a bunch of times) but the new vm behaves the same way.
Thanks for getting back to me.
Comment 6 Veteran 2017-07-19 00:10:58 EDT
Some things I've been seeing while researching make me wonder if it is a conflict between dbus.service and dbus-launch (I am using xfce4; dbus-launch is in /etc/X11/xinit/xinitrc.d/00-start-message-bus.sh and /etc/xdg/xfce4/xinitrc.

I just don't know enough about dbus.
Comment 7 Caolan McNamara 2017-07-22 09:12:15 EDT
I rather expect this is a duplicate of bug 1468436 given the i686 arch tag
Comment 8 David H. Gutteridge 2017-07-24 21:19:31 EDT
(In reply to Caolan McNamara from comment #7)
> I rather expect this is a duplicate of bug 1468436 given the i686 arch tag

This is the same as what I'm seeing, and disabling Java requirements for LibreOffice (in my case, LanguageTool for Writer) worked around the problem for me. (I haven't tried reverting to kernel 4.11.5, as suggested in the other bug.)
Comment 9 David H. Gutteridge 2017-09-02 14:04:14 EDT
Please see the workaround in https://bugzilla.redhat.com/show_bug.cgi?id=1468436#c23. If this addresses your issue, this is a duplicate bug (I'm pretty certain it is, anyway).
Comment 10 Veteran 2017-12-05 11:28:14 EST
This is also a problem in F27 i686. Removing the java components makes it usable, but I need the xslt filters.
Comment 11 Veteran 2017-12-05 11:43:06 EST
David H. Gutteridge thank you for posting the work around. That works on F27 also.
Comment 12 Veteran 2017-12-05 11:46:56 EST
I am closing this as it isn't a Libreoffice bug.
Comment 13 David Tardon 2017-12-24 04:35:35 EST

*** This bug has been marked as a duplicate of bug 1468436 ***

Note You need to log in before you can comment on or make changes to this bug.