Bug 1471318 - avahi .local domains are not being resolving in Fedora 26
avahi .local domains are not being resolving in Fedora 26
Status: NEW
Product: Fedora
Classification: Fedora
Component: nss-mdns (Show other bugs)
28
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Adam Goode
Fedora Extras Quality Assurance
: Reopened, Triaged
Depends On: 1577243
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-14 21:35 EDT by Ildar Akhmetgaleev
Modified: 2018-06-07 09:07 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-03-19 04:32:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ildar Akhmetgaleev 2017-07-14 21:35:45 EDT
Description of problem:
After upgrade from Fedora 25 to 26 .local domains are not being resolving any more.

Problem solved by changing one line in /etc/nsswitch.conf
- hosts:      files dns
+ hosts:      files mdns4_minimal [NOTFOUND=return] dns



Version-Release number of selected component (if applicable):
avahi 0.6.32-7.fc26
glibc 2.25-7.fc26


How reproducible:
Every time.


Steps to Reproduce:
1. ping somehost.local

Actual results:
host not found


Expected results:
host resolved


Additional info:
I am using network manager with dnsmasq extension.
Comment 1 Simon Gerhards 2017-07-23 08:56:37 EDT
Additional info: On my system "dnf reinstall nss-mdns" made the necessary change to /etc/nsswitch.conf.
Comment 2 Adam Goode 2018-03-18 13:55:19 EDT
Can this be closed?
Comment 3 Ildar Akhmetgaleev 2018-03-19 00:38:44 EDT
(In reply to Adam Goode from comment #2)
> Can this be closed?

I can not check how it works in current version because I have no Fedora on my computers right now.
Comment 4 Rex Dieter 2018-03-19 04:32:37 EDT
I have a strong recollection that comment #1 is correct.  Feel free to re-open if problems persist.
Comment 5 David Haller 2018-05-04 09:17:03 EDT
Affects me in Fedora 28, reinstalling nss-mdns fixed it.
Comment 6 Christian Kellner 2018-05-21 05:08:41 EDT
I just ran into this problem on a fresh F28 installation. 

→ cat /etc/nsswitch.conf
[...]
hosts:      files dns myhostname
[...]

→ dnf info nss-mdns

Installed Packages
Name         : nss-mdns
Version      : 0.14.1
Release      : 1.fc28
Arch         : x86_64
Size         : 136 k
Source       : nss-mdns-0.14.1-1.fc28.src.rpm
Repo         : @System
From repo    : anaconda
[...]

→ sudo dnf reinstall nss-mdns
Fixed the issue, so I would say the problem indeed still persists.
Comment 7 Rex Dieter 2018-05-21 15:16:57 EDT
If re-installing nss-mdns , it's likely only because of it's scriptlets:

%post
/sbin/ldconfig
# sed-fu to add mdns4_minimal to the hosts line of /etc/nsswitch.conf
if [ -f /etc/nsswitch.conf ] ; then
        sed -i.bak '
                /^hosts:/ !b
                /\<mdns\(4\|6\)\?\(_minimal\)\?\>/ b
                s/\([[:blank:]]\+\)dns\>/\1mdns4_minimal [NOTFOUND=return] dns/g
                ' /etc/nsswitch.conf
fi

which is essentially what linked bug #1577243 is about
Comment 8 Bastien Nocera 2018-06-07 09:07:56 EDT
The post is probably missing a requires on glibc already being installed. If you still have the install logs (usually in /root) you should see that nss-mdns gets installed before glibc.

Note You need to log in before you can comment on or make changes to this bug.