Bug 1471329 - PyOpenCL does not work due to dated python-compyte
PyOpenCL does not work due to dated python-compyte
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: python-compyte (Show other bugs)
26
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Igor Gnatenko
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-14 22:52 EDT by maarten
Modified: 2017-07-22 23:56 EDT (History)
1 user (show)

See Also:
Fixed In Version: python-compyte-0.0.1-0.8.git11dc003.fc26
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-22 23:56:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description maarten 2017-07-14 22:52:19 EDT
Description of problem:
Cannot import pyopencl.array because of outdated compyte

Version-Release number of selected component (if applicable):
0.7.gitac1c71d.fc26

How reproducible:
100%

Steps to Reproduce:
1. dnf install python3-pyopencl #compyte is a dependency of pyopencl
2. python3 -c "from pyopencl import array"

Actual results:
Traceback (most recent call last):
  File "<string>", line 1, in <module>
  File "/usr/lib64/python3.6/site-packages/pyopencl/array.py", line 37, in <module>
    from compyte.array import (
ImportError: cannot import name 'equal_strides'

Expected results:
No ImportError

Additional info:
Comment 1 Fedora Update System 2017-07-15 04:29:13 EDT
python-pyopencl-2017.2-1.fc26 python-pytools-2017.3-1.fc26 python-compyte-0.0.1-0.8.git11dc003.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-4b45695158
Comment 2 Fedora Update System 2017-07-16 17:22:13 EDT
python-compyte-0.0.1-0.8.git11dc003.fc26, python-pyopencl-2017.2-1.fc26, python-pytools-2017.3-1.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-4b45695158
Comment 3 Fedora Update System 2017-07-22 23:56:36 EDT
python-compyte-0.0.1-0.8.git11dc003.fc26, python-pyopencl-2017.2-1.fc26, python-pytools-2017.3-1.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.