Bug 1471430 - SELinux is preventing appsrc0:src from 'write' accesses on the file /home/vm/orcexec.5LhOM5.
SELinux is preventing appsrc0:src from 'write' accesses on the file /home/vm/...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
26
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Lukas Vrabec
Fedora Extras Quality Assurance
abrt_hash:1c769d5ef3cd48d6be56d6bc81c...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-15 17:58 EDT by vaughn miller
Modified: 2017-07-20 14:49 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-18 14:08:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description vaughn miller 2017-07-15 17:58:27 EDT
Description of problem:
Browsing network share
SELinux is preventing appsrc0:src from 'write' accesses on the file /home/vm/orcexec.5LhOM5.

*****  Plugin restorecon (99.5 confidence) suggests   ************************

If you want to fix the label. 
/home/vm/orcexec.5LhOM5 default label should be user_home_t.
Then you can run restorecon. The access attempt may have been stopped due to insufficient permissions to access a parent directory in which case try to change the following command accordingly.
Do
# /sbin/restorecon -v /home/vm/orcexec.5LhOM5

*****  Plugin catchall (1.49 confidence) suggests   **************************

If you believe that appsrc0:src should be allowed write access on the orcexec.5LhOM5 file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# ausearch -c 'appsrc0:src' --raw | audit2allow -M my-appsrc0src
# semodule -X 300 -i my-appsrc0src.pp

Additional Information:
Source Context                unconfined_u:unconfined_r:thumb_t:s0-s0:c0.c1023
Target Context                unconfined_u:object_r:user_home_dir_t:s0
Target Objects                /home/vm/orcexec.5LhOM5 [ file ]
Source                        appsrc0:src
Source Path                   appsrc0:src
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.13.1-259.fc26.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 4.11.9-300.fc26.x86_64 #1 SMP Wed
                              Jul 5 16:21:56 UTC 2017 x86_64 x86_64
Alert Count                   5
First Seen                    2017-07-15 17:57:13 EDT
Last Seen                     2017-07-15 17:57:52 EDT
Local ID                      bd8a4ce3-f598-4943-a29e-6f1568ec0502

Raw Audit Messages
type=AVC msg=audit(1500155872.900:470): avc:  denied  { write } for  pid=8962 comm="appsrc0:src" path="/home/vm/orcexec.5LhOM5" dev="dm-2" ino=32393366 scontext=unconfined_u:unconfined_r:thumb_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:user_home_dir_t:s0 tclass=file permissive=0


Hash: appsrc0:src,thumb_t,user_home_dir_t,file,write

Version-Release number of selected component:
selinux-policy-3.13.1-259.fc26.noarch

Additional info:
component:      selinux-policy
reporter:       libreport-2.9.1
hashmarkername: setroubleshoot
kernel:         4.11.9-300.fc26.x86_64
type:           libreport
Comment 1 vaughn miller 2017-07-18 11:30:04 EDT
Description of problem:
Connected to a network share

Version-Release number of selected component:
selinux-policy-3.13.1-260.1.fc26.noarch

Additional info:
reporter:       libreport-2.9.1
hashmarkername: setroubleshoot
kernel:         4.11.9-300.fc26.x86_64
type:           libreport
Comment 2 Lukas Vrabec 2017-07-18 14:08:31 EDT
*****  Plugin restorecon (99.5 confidence) suggests   ************************

If you want to fix the label. 
/home/vm/orcexec.5LhOM5 default label should be user_home_t.
Then you can run restorecon. The access attempt may have been stopped due to insufficient permissions to access a parent directory in which case try to change the following command accordingly.
Do
# /sbin/restorecon -v /home/vm/orcexec.5LhOM5
Comment 3 vaughn miller 2017-07-20 14:49:59 EDT
Description of problem:
opened a network share

Version-Release number of selected component:
selinux-policy-3.13.1-260.1.fc26.noarch

Additional info:
reporter:       libreport-2.9.1
hashmarkername: setroubleshoot
kernel:         4.11.10-300.fc26.x86_64
type:           libreport

Note You need to log in before you can comment on or make changes to this bug.