Bug 1471480 - http2 as seperate module no longer working correctly
http2 as seperate module no longer working correctly
Status: CLOSED DUPLICATE of bug 1470289
Product: Fedora
Classification: Fedora
Component: mod_http2 (Show other bugs)
24
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Luboš Uhliarik
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-16 06:26 EDT by customercare
Modified: 2017-07-17 05:56 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-17 05:40:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description customercare 2017-07-16 06:26:46 EDT
Description of problem:

ALPN is choosing http/1.1 instead of the prefered and enabled h2.


used configuration : 

	LoadModule http2_module modules/mod_http2.so

	Protocols h2 h2c http/1.1

	ProtocolsHonorOrder On

this was working correctly, before the mod got pulled from httpd package and put into it's own package seperatly!

No clue how it got screwed up, but it did. 


Version-Release number of selected component (if applicable):

mod_http2-1.10.7-1.fc24.x86_64
httpd-2.4.27-2.fc24.x86_64

How reproducible:

see below

Actual results:

none working http2

Expected results:

h2 used when requested

Additional info:

$ curl -v --http2 https://my-gaestebuch.de/
*   Trying 83.246.80.141...
* TCP_NODELAY set
* Connected to my-gaestebuch.de (83.246.80.141) port 443 (#0)
* Initializing NSS with certpath: sql:/etc/pki/nssdb
*   CAfile: /etc/pki/tls/certs/ca-bundle.crt
  CApath: none
* ALPN, server accepted to use http/1.1
* SSL connection using TLS_ECDHE_RSA_WITH_AES_128_GCM_SHA256
* Server certificate:
* 	subject: CN=my-gaestebuch.de
* 	start date: Jun 01 12:34:00 2017 GMT
* 	expire date: Aug 30 12:34:00 2017 GMT
* 	common name: my-gaestebuch.de
* 	issuer: CN=Let's Encrypt Authority X3,O=Let's Encrypt,C=US
> GET / HTTP/1.1
> Host: my-gaestebuch.de
> User-Agent: curl/7.51.0
> Accept: */*
> 
< HTTP/1.1 200 OK
< Date: Sun, 16 Jul 2017 10:22:49 GMT
< Server: Apache/2.4.27 (Fedora) OpenSSL/1.0.2k-fips
< Upgrade: h2,h2c
< Connection: Upgrade
< Transfer-Encoding: chunked
< Content-Type: text/html; charset=iso-8859-15
< 
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN"
        "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="de" lang="de">
...
Comment 1 Luboš Uhliarik 2017-07-17 05:21:43 EDT
Please, check this bug:

https://bugzilla.redhat.com/show_bug.cgi?id=1470289
Comment 2 Joe Orton 2017-07-17 05:40:43 EDT
This has nothing to do with the separation into a separate package, it's the same behaviour in httpd 2.4.27, unfortunately.  See this upstream bug for discussion:

https://github.com/icing/mod_h2/issues/142
Comment 3 customercare 2017-07-17 05:56:54 EDT

*** This bug has been marked as a duplicate of bug 1470289 ***

Note You need to log in before you can comment on or make changes to this bug.