Bug 1471519 - Error in /etc/tmpfiles.d/ entry leads to /var/run/nologin still there after boot
Error in /etc/tmpfiles.d/ entry leads to /var/run/nologin still there after boot
Status: POST
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: systemd-maint
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2017-07-16 11:53 EDT by Tom Horsley
Modified: 2018-03-23 04:45 EDT (History)
10 users (show)

See Also:
Fixed In Version: systemd-236-1.fc28
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Tom Horsley 2017-07-16 11:53:55 EDT
Description of problem:
I was copying stuff from my old root to my new fedora 26 root. One of the files I copied was /etc/tmpfiles.d/stunnel.conf which looks like:

d	/var/run/stunnel	0755	stunnel	stunnel

That refers to the stunnel user and group, but I foolishly failed to create the stunnel system user in the fedora 26 root.

That leads to the entirely unexpected and totally wacky side-effect of the /var/run/nologin file hanging around long after the system has actually finished booting.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.see above

Actual results:
Have to manually delete /var/run/nologin to login as non-root

Expected results:
Normal login

Additional info:
This seems like busted error handling. I'd expect it to ignore the tmpfiles.d entry that makes no sense and spew a log message about it, not wind up with things so broken I can't login.
Comment 1 Zbigniew Jędrzejewski-Szmek 2017-07-16 12:01:50 EDT
Comment 2 Patricia Moeller 2017-10-27 03:20:09 EDT
I ran into similar issues. Could you please point out how you figured out which tmpfiles.d conf file caused the issue on your side?
Comment 3 Tom Horsley 2017-10-27 06:04:39 EDT
Not much help probably: I only had one that I manually created, so I figured it must be that one.
Comment 4 Tom Horsley 2017-11-18 21:51:01 EST
Just for curiosity, I made the same error again when installing fedora 27 and the same nologin problem is caused by a bad tmpfile configuration (at least it wasn't as confusing this time :-).
Comment 5 Zbigniew Jędrzejewski-Szmek 2018-03-23 04:45:49 EDT
This is fixed in F28, but backporting to F27 is complicated. I'll leave this in POST state for now.

Note You need to log in before you can comment on or make changes to this bug.