Bug 1471688 - Message for ceilometer deprecation: Pankoclient is in the list of possible options
Message for ceilometer deprecation: Pankoclient is in the list of possible op...
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: instack-undercloud (Show other bugs)
12.0 (Pike)
Unspecified Unspecified
low Severity low
: rc
: 12.0 (Pike)
Assigned To: James Slagle
Sasha Smolyak
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-17 05:17 EDT by Sasha Smolyak
Modified: 2017-12-13 16:42 EST (History)
9 users (show)

See Also:
Fixed In Version: instack-undercloud-7.2.1-0.20170821194210.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-12-13 16:42:20 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 490044 None None None 2017-08-03 15:24 EDT

  None (edit)
Description Sasha Smolyak 2017-07-17 05:17:43 EDT
Description of problem:
>ceilometer event-type-list

Getting the message: 
/usr/lib/python2.7/site-packages/ceilometerclient/shell.py:177: UserWarning: ceilometerclient is now deprecated as the Ceilometer API has been deprecated. Please use either aodhclient, pankoclient or gnocchiclient.
  "ceilometerclient is now deprecated as the Ceilometer API has "

1. The message has pankoclient as one of the options, although there is no pankoclient installed (panko user, endpoint and service are installed). 

2. The message seems to be broken - 2 lines, first the warning itself and then le line in brackets.

Version-Release number of selected component (if applicable):
puppet-panko-11.2.0-0.20170704155555.7335c05.el7ost.noarch
python-ceilometerclient-2.9.0-0.20170613145842.3b4e35a.el7ost.noarch
python-ceilometermiddleware-1.0.1-0.20170228134010.6ba005f.el7.noarch
puppet-ceilometer-11.2.0-0.20170710180028.df37477.el7ost.noarch


How reproducible:
100%

Steps to Reproduce:
1. Switch to overcloud
2. Write 
>ceilometer event-type-list

Actual results:
Message appearing twice, mentioning pankoclient

Expected results:
Message appears once, no pankoclient in the list

Additional info:
Comment 10 errata-xmlrpc 2017-12-13 16:42:20 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:3462

Note You need to log in before you can comment on or make changes to this bug.