Bug 1471703 - HPE BL460c Gen9 blanks console during boot, nomodeset is required to see the output in ILO
HPE BL460c Gen9 blanks console during boot, nomodeset is required to see the ...
Status: CLOSED NOTABUG
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: realtime-kernel (Show other bugs)
2.5
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Daniel Bristot de Oliveira
Jiri Kastner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-17 05:33 EDT by Andreas Bleischwitz
Modified: 2017-07-20 10:24 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-20 10:24:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
DMI-decode HPE BL460c Gen9 (41.75 KB, text/plain)
2017-07-17 05:33 EDT, Andreas Bleischwitz
no flags Details

  None (edit)
Description Andreas Bleischwitz 2017-07-17 05:33:42 EDT
Created attachment 1299749 [details]
DMI-decode HPE BL460c Gen9

Description of problem:
kernel-3.10.0-514.rt56.210.el6rt.x86_64 introduced a console video-mode switch, which renders the ILO-console to blank. In order to be able to bring back the output, one has to add "nomodeset" to the kernel-commandline.

Version-Release number of selected component (if applicable):
* HPE BL460c Gen9
* kernel-3.10.0-514.rt56.210.el6rt.x86_64 fails
* kernel-3.10.0-514.el7 from RHEL7.3 GA does not suffer from that issue

How reproducible:

Steps to Reproduce:
1. Install kernel-3.10.0-514.rt56.210.el6rt.x86_64 on HPE BL460c Gen9
2. boot system and open ILO-console
3. see the system blanking after kernel-init

Actual results:
Console blanks and no output is shown

Expected results:
Output is printed until login-prompt


Additional info:
Kernel-commandline: root=/dev/mapper/VGlocal-LVroot rd_NO_LUKS rd_LVM_LV=VGlocal/LVswap LANG=en_US.UTF-8 rd_NO_MD rd_LVM_LV=VGlocal/LVroot  KEYBOARDTYPE=pc KEYTABLE=de-latin1 crashkernel=256M rd_NO_DM SYSFONT=latarcyrheb-sun16 selinux=0 nosoftlockup mce=off printk.time=1 elevator=deadline intel_idle.max_cstate=0 processor.max_cstate=0 idle=poll NOHZ=on numa_balancing=disable noht ipmi_si.force_kipmid=0 nmi_watchdog=0 pcie_aspm=performance hpet=disabled nohalt nohz=on console=ttyS0,115200 console=tty0 consoleblank=0
Comment 2 Daniel Bristot de Oliveira 2017-07-17 10:06:15 EDT
Hi,

An additional information, the customer already tried the kernel with the fix for the BZ1452769 (kernel-rt-3.10.0-514.rt56.228.el6rt.x86_64) but the problem is still reproducing.

So, I requested the loan of an HPE BL460c Gen9 to try to reproduce the problem internally, but I am still waiting for the approval.

Andreas, I saw that gsslab has a lot of HPE BL460c Gen9, so, while waiting for the load, could you please try to reproduce the problem in a GSSLAB box?
This could speed up the fix.

Thanks in advance,
-- Daniel
Comment 5 Andreas Bleischwitz 2017-07-20 10:24:55 EDT
We found that kernel-commandline "video=640x400" rendered the console to blank. Changing this to "video=640x480" fixed that issue.

We also confirmed that https://bugzilla.redhat.com/1452769 fixed that issue as the previous kernel blanked the console even with the correct video settings.

So closing this case.

Note You need to log in before you can comment on or make changes to this bug.