Bug 1471728 - [wpa_supplicant] TLS: Failed to load private key
[wpa_supplicant] TLS: Failed to load private key
Status: CLOSED DUPLICATE of bug 1465138
Product: Fedora
Classification: Fedora
Component: wpa_supplicant (Show other bugs)
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Lubomir Rintel
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2017-07-17 06:51 EDT by Veske
Modified: 2017-07-17 15:13 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2017-07-17 15:13:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
wpa_supplicant error logs (1.40 KB, text/plain)
2017-07-17 06:51 EDT, Veske
no flags Details

  None (edit)
Description Veske 2017-07-17 06:51:17 EDT
Created attachment 1299780 [details]
wpa_supplicant error logs

Description of problem:

After update to Fedora 26, my connection to private network though TLS does not work anymore. wpa_supplicant is throwing errors shown in the attachment.

Version-Release number of selected component (if applicable):
OpenSSL 1.1.0f-fips  25 May 2017
wpa_supplicant v2.6

How reproducible:

Attempt to make a TLS connection though NetworkManager Gnome applet and look at wpa_supplicant logs when establishing connection.

Actual results:
Connection fails with error TLS: Failed to load private key

Expected results:
Connection should work like it did in Fedora 25.

Additional info:

I found a similar bug on Archlinux bug tracker: https://bugs.archlinux.org/task/54233

It seems that the Arch Linux maintainers fixed the issue already and released the new version for wpa_supplicant. Would be great to have this fix on Fedora also.
Comment 1 Veske 2017-07-17 07:05:46 EDT
I was able to work around this bug by removing passphrase from my private key. This is not a very good solution tough and I think this issue should be resolved.
Comment 2 Beniamino Galvani 2017-07-17 15:13:27 EDT

*** This bug has been marked as a duplicate of bug 1465138 ***

Note You need to log in before you can comment on or make changes to this bug.