Bug 1471735 - Rebase Neutron Mitaka to 8.4.0
Rebase Neutron Mitaka to 8.4.0
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-neutron (Show other bugs)
9.0 (Mitaka)
Unspecified Unspecified
high Severity high
: zstream
: 9.0 (Mitaka)
Assigned To: belharar
Ofer Blaut
: Triaged, ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-17 07:10 EDT by belharar
Modified: 2017-08-30 10:07 EDT (History)
5 users (show)

See Also:
Fixed In Version: openstack-neutron-8.4.0-1.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-30 10:07:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description belharar 2017-07-17 07:10:44 EDT
Rebase Neutron Mitaka to its most recent (and last upstream) release - 8.4.0, in order to align it with the recent rebase of neutron-lbaas (rhbz#1343937).
Comment 1 belharar 2017-07-19 08:05:05 EDT
Rebase was sent for review via email by Nir M.
Comment 2 Nir Magnezi 2017-07-20 03:20:54 EDT
c361055 Check for unbound ports in L3 RPC handler
121283d Only send string values to OVSDB other_config column
c96a1f7 XenAPI: add support for conntrack with XenServer
732fd61 Support alembic 0.8.9 in test_autogen_process_directives
3a7c9d0 Truncate IPDevice's name to interface max size
16820d8 ovs agent, native ARP response: set Eth src/dst
052f2eb OVS agent: configure both OF10 and OF13
a1ca8ee ovs-agent: Catch exceptions in agent_main_wrapper
6f9e575 Unplug external device when delete snat namespace
8e2f6ce Check for l3 agents count before router update
dd6fd62 Solve unexpected NoneType returned by _get_routers_can_schedule.
b407e92 Ignore gre0 and gretap0 devices in netns cleanup script.
7c0b05f Allow more time for DB migration tests
5389dd7 Don't depend on translated strings for error check
7695027 callbacks: Make the value of FLOATING_IP match with api resource
b5ab5a4 Parse the output of ip route more robustly
7b7e562 Add unit tests for ip_lib.get_routing_table
284d32f Add L3 HA test with linux bridge
7e616cb ovs-agent: Close ryu app on all exceptions
67e334b Reduce IP link show calls for SR-IOV scan loop
962de7f gate_hook: Add a no-op rally case
459437c Use subqueries for rbac_entries and subnets<->network
7cb6942 DVR: Fix race condition in creation of fip gateway
a66af42 Delete default route if no gateway in external net
4e77829 Correctly print --limit value passed via API
5413853 Skip larger than /64 subnets in DHCP agent
7455b47 Delete conntrack when remote ipset member removed
2580bcb SRIOV: don't block report_state with device count
c86f1ab Use revision to discard stale DHCP updates
339e174 Changing arping command execute to accept 1 as extra OK code
46978e4 l3-ha: Send gratuitous ARP when new floating IP is added
90844c5 DVR: remove misleading error log
2ee6e58 Fix "failed unplugging ha interface" error when deleting router
fd082cd Avoid trace in _notify_l3_agent_ha_port_update
8834107 LinuxBridge: Pass host into get_devices_details_list
0010301 Ensure there are fdb_entries before iterating
9dd4ad1 Update metadata proxy when subnet add/delete
4339740 Check if namespace exists before getting devices
577a472 ovsfw: Add a dl_type match for action=ct flows
dd75f7e ovsfw: fix troublesome port_rule_masking
5860fb2 Check for ha port to become ACTIVE
c06ff65 l2pop fdb flows for HA router ports
369faa2 Get rid of double-join to rbac_entries without filter
1d610fc Add 169.254.169.254 when enable force_metadata
67d8556 Move class properties to instances for dhcp tests
Comment 7 errata-xmlrpc 2017-08-30 10:07:41 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2552

Note You need to log in before you can comment on or make changes to this bug.