Bug 1471774 - (CVE-2017-11329) CVE-2017-11329 glpi: SQL injection in ajax/getDropdownValue.php
CVE-2017-11329 glpi: SQL injection in ajax/getDropdownValue.php
Status: NEW
Product: Security Response
Classification: Other
Component: vulnerability (Show other bugs)
unspecified
All Linux
medium Severity medium
: ---
: ---
Assigned To: Red Hat Product Security
impact=moderate,public=20170712,repor...
: Security
Depends On: 1471776 1471775
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-17 08:24 EDT by Adam Mariš
Modified: 2017-07-17 08:25 EDT (History)
2 users (show)

See Also:
Fixed In Version: glpi 9.1.5
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam Mariš 2017-07-17 08:24:35 EDT
GLPI before 9.1.5 allows SQL injection via an ajax/getDropdownValue.php request with an entity_restrict parameter that is not a list of integers.

Upstream patch:

https://github.com/trasher/glpi/commit/4eda802608d65091777596c5d0e0b0c4fefbd563
Comment 1 Adam Mariš 2017-07-17 08:25:03 EDT
Created glpi tracking bugs for this issue:

Affects: epel-7 [bug 1471776]
Affects: fedora-all [bug 1471775]

Note You need to log in before you can comment on or make changes to this bug.