Bug 1471789 - slave27 has been disabled because of "failed to write new configuration file .git/config.lock"
slave27 has been disabled because of "failed to write new configuration file ...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: project-infrastructure (Show other bugs)
3.11
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: bugs@gluster.org
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-17 08:44 EDT by Niels de Vos
Modified: 2017-07-17 09:31 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-17 09:31:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Niels de Vos 2017-07-17 08:44:04 EDT
Regression tests on slave27 fail like this:

Building remotely on slave27.cloud.gluster.org (rackspace_regression_2gb) in workspace /home/jenkins/root/workspace/centos6-regression
 > git rev-parse --is-inside-work-tree # timeout=10
Fetching changes from the remote Git repository
 > git config remote.origin.url git://review.gluster.org/glusterfs.git # timeout=10
ERROR: Error fetching remote repo 'origin'
hudson.plugins.git.GitException: Failed to fetch from git://review.gluster.org/glusterfs.git
	at hudson.plugins.git.GitSCM.fetchFrom(GitSCM.java:812)
	at hudson.plugins.git.GitSCM.retrieveChanges(GitSCM.java:1079)
	at hudson.plugins.git.GitSCM.checkout(GitSCM.java:1110)
	at hudson.scm.SCM.checkout(SCM.java:495)
	at hudson.model.AbstractProject.checkout(AbstractProject.java:1276)
	at hudson.model.AbstractBuild$AbstractBuildExecution.defaultCheckout(AbstractBuild.java:560)
	at jenkins.scm.SCMCheckoutStrategy.checkout(SCMCheckoutStrategy.java:86)
	at hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:485)
	at hudson.model.Run.execute(Run.java:1735)
	at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43)
	at hudson.model.ResourceController.execute(ResourceController.java:97)
	at hudson.model.Executor.run(Executor.java:405)
Caused by: hudson.plugins.git.GitException: Command "git config remote.origin.url git://review.gluster.org/glusterfs.git" returned status code 4:
stdout: 
stderr: error: failed to write new configuration file .git/config.lock


The slave has been disabled in Jenkins. Please re-enable the slave once the problem is addressed.

https://build.gluster.org/computer/slave27.cloud.gluster.org/
Comment 1 Nigel Babu 2017-07-17 09:31:07 EDT
This seems to be because the disk ran out of space. A large tar for log files by the release-3.8-fb branch seems to be eating up all the space. I've cleared it up and send a note to Jeff.

See: http://lists.gluster.org/pipermail/gluster-devel/2017-July/053328.html

The node is back in the pool.

Note You need to log in before you can comment on or make changes to this bug.