Bug 1471790 - [Brick Multiplexing] : cluster.brick-multiplex has no description.
[Brick Multiplexing] : cluster.brick-multiplex has no description.
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: glusterd (Show other bugs)
mainline
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Samikshan Bairagya
brick-multiplexing
:
Depends On:
Blocks: 1444790
  Show dependency treegraph
 
Reported: 2017-07-17 08:49 EDT by Samikshan Bairagya
Modified: 2017-09-05 13:36 EDT (History)
10 users (show)

See Also:
Fixed In Version: glusterfs-3.12.0
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1444790
Environment:
Last Closed: 2017-09-05 13:36:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Samikshan Bairagya 2017-07-17 08:49:01 EDT
+++ This bug was initially created as a clone of Bug #1444790 +++

Description of problem:
------------------------

gluster v set help shows no description for the Brick MUXing tunable :


[root@gqas013 ~]# gluster v set help|grep cluster.brick-multiplex
[root@gqas013 ~]# 

[root@gqas013 ~]# gluster v set help|grep cluster.brick
[root@gqas013 ~]# 



Version-Release number of selected component (if applicable):
-------------------------------------------------------------

glusterfs-3.8.4-23.el7rhgs.x86_64


How reproducible:
-----------------

Always.
Comment 1 Worker Ant 2017-07-17 08:57:07 EDT
REVIEW: https://review.gluster.org/17790 (glusterd: Add description field to global options for brick-mux) posted (#1) for review on master by Samikshan Bairagya (samikshan@gmail.com)
Comment 2 Worker Ant 2017-07-17 09:58:07 EDT
REVIEW: https://review.gluster.org/17790 (glusterd: Add description field to global options for brick-mux) posted (#2) for review on master by Samikshan Bairagya (samikshan@gmail.com)
Comment 3 Worker Ant 2017-07-17 15:21:08 EDT
COMMIT: https://review.gluster.org/17790 committed in master by Jeff Darcy (jeff@pl.atyp.us) 
------
commit b14f26a869c056fb9951e481ae20f3887edb743d
Author: Samikshan Bairagya <samikshan@gmail.com>
Date:   Mon Jul 17 17:38:48 2017 +0530

    glusterd: Add description field to global options for brick-mux
    
    Currently the "cluster.brick-multiplex" and
    "cluster.max-bricks-per-process" options do not show anything in
    the description field when gluster volume set help is called. This
    commit adds the description fields for these 2 options.
    
    Change-Id: I3d162c61fa2774dd994f046e305d457f0fd43192
    BUG: 1471790
    Signed-off-by: Samikshan Bairagya <samikshan@gmail.com>
    Reviewed-on: https://review.gluster.org/17790
    Reviewed-by: Atin Mukherjee <amukherj@redhat.com>
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Gaurav Yadav <gyadav@redhat.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
Comment 4 Shyamsundar 2017-09-05 13:36:59 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.12.0, please open a new bug report.

glusterfs-3.12.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/announce/2017-September/000082.html
[2] https://www.gluster.org/pipermail/gluster-users/

Note You need to log in before you can comment on or make changes to this bug.