Bug 1471793 - USS + CIFS : ls on .snaps directory gives Input/Output error on CIFS mount
USS + CIFS : ls on .snaps directory gives Input/Output error on CIFS mount
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: snapshot (Show other bugs)
3.2
x86_64 Linux
unspecified Severity urgent
: ---
: RHGS 3.2.0 Async
Assigned To: Anoop C S
Anil Shah
: Regression, ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-17 08:53 EDT by Anil Shah
Modified: 2017-08-01 03:46 EDT (History)
6 users (show)

See Also:
Fixed In Version: glusterfs-3.8.4-18.6
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-01 03:46:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Anil Shah 2017-07-17 08:53:54 EDT
Description of problem:

ls on .snaps directory gives Input/output error on cifs mount.
However .snaps is visible on windows client.

Version-Release number of selected component (if applicable):

glusterfs-3.8.4-18.5.el7rhgs.x86_64

How reproducible:
100%


Steps to Reproduce:
1. Create dist-rep volume
2. Enable uss 
3. Create snapshot and activate it

Actual results:

ls on .snaps fails with input/output error

Expected results:

ls on .snaps directory should be successful.

Additional info:
Comment 8 Anil Shah 2017-07-25 08:28:01 EDT
cd .snaps is accessible .
Bug verified on build 3.8.4-18.6
Comment 10 errata-xmlrpc 2017-08-01 03:46:44 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2339

Note You need to log in before you can comment on or make changes to this bug.