Bug 1471799 - gdeploy 2.0.2 should be backward compatible as per cockpit requirements
gdeploy 2.0.2 should be backward compatible as per cockpit requirements
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: gdeploy (Show other bugs)
3.3
Unspecified Unspecified
unspecified Severity high
: ---
: RHGS 3.3.0
Assigned To: Sachidananda Urs
RamaKasturi
:
Depends On:
Blocks: Gluster-HC-3 1417151
  Show dependency treegraph
 
Reported: 2017-07-17 09:07 EDT by RamaKasturi
Modified: 2017-09-21 00:52 EDT (History)
6 users (show)

See Also:
Fixed In Version: gdeploy-2.0.2-13
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-09-21 00:52:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description RamaKasturi 2017-07-17 09:07:26 EDT
Description of problem:
When gdeploy 2.0.2 releases it will break any new installations of RHHI as the script files present in the generated gdeploy conf file points to a location which does not exist. 

Version-Release number of selected component (if applicable):
gdeploy 2.0.2

How reproducible:
Always

Steps to Reproduce:
1. Install RHHI setup using ansible 2.3 and gdeploy 2.0.2
2.
3.

Actual results:
Installation fails and does not proceed further.

Expected results:
Installation should succeed.

Additional info:
This cannot be fixed at RHV layer since there are two releases which are happening RHV 4.1.4 before RHGS 3.3 and RHV 4.1.5 which is after 3.3. 

If we fix plan to fix this bug at 4.1.4 release it will break installation of RHHI since RHGS 3.3 is not released.

If we plan to fix this bug at RHV 4.1.5 release then this will break installation of RHHI before RHV 4.1.5 releases.

This is the reason why we would need to fix this at gdeploy level and hence proposing this as blocker.
Comment 4 Sachidananda Urs 2017-07-19 05:21:53 EDT
This is a spec file change, for now the scripts are copied to both:

/usr/share/gdeploy/scripts and
/usr/share/ansible/gdeploy/scripts

Will remove /usr/share/ansible/gdeploy/scripts in future.
Comment 5 RamaKasturi 2017-07-24 05:42:24 EDT
Moving this bug back as installation fails with error as the script name for 'blacklist_all_disks.sh' has not been changed in cockpit UI. The script can be renamed at a later point of time. For now the script name has to be renamed tp disable-multipath.sh.
Comment 6 RamaKasturi 2017-07-24 06:25:01 EDT
Please rename the script blacklist_all_disks.sh to disable-multipath.sh to meet the cockpit requirements.
Comment 9 RamaKasturi 2017-07-24 08:48:43 EDT
Will verify this bug once the bug https://bugzilla.redhat.com/show_bug.cgi?id=1474350 moves to on_qa.
Comment 10 RamaKasturi 2017-07-31 06:21:59 EDT
Verified and works fine with build gdeploy-2.0.2-14.el7rhgs.noarch

I see that scripts with this version are present in both the paths /usr/share/ansible/gdeploy/scripts and /usr/share/gdeploy/scripts to meet cockpit requirements.

[root@yarrow-nic2 ~]# ls -l /usr/share/ansible/gdeploy/scripts/
total 16
-rwxr-xr-x. 1 root root 1218 Jul 28 16:23 blacklist_all_disks.sh
-rwxr-xr-x. 1 root root  512 Jul 28 16:23 disable-gluster-hooks.sh
-rwxr-xr-x. 1 root root 1218 Jul 28 16:23 disable-multipath.sh
-rwxr-xr-x. 1 root root 3476 Jul 28 16:23 grafton-sanity-check.sh

[root@yarrow-nic2 ~]# ls -l /usr/share/gdeploy/scripts/
total 16
-rwxr-xr-x. 1 root root 1218 Jul 28 16:23 blacklist_all_disks.sh
-rwxr-xr-x. 1 root root  512 Jul 28 16:23 disable-gluster-hooks.sh
-rwxr-xr-x. 1 root root 1218 Jul 28 16:23 disable-multipath.sh
-rwxr-xr-x. 1 root root 3476 Jul 28 16:23 grafton-sanity-check.sh
Comment 12 errata-xmlrpc 2017-09-21 00:52:20 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2777

Note You need to log in before you can comment on or make changes to this bug.