Bug 147180 - aterm doesn't read ~/.Xdefaults or ~/.Xresources
aterm doesn't read ~/.Xdefaults or ~/.Xresources
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: aterm (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Andreas Bierfert
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-04 13:02 EST by chris
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-11 07:44:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description chris 2005-02-04 13:02:53 EST
Summary says it all, really - aterm doesn't read either of those
files.  I've done an strace, and neither of them figures.

The manpage says it's supposed to try both of them.
Comment 1 Andreas Bierfert 2005-02-04 18:34:53 EST
Could you give more info (content of your .Xdefaults/.Xresources) and
aterm version (both rpm and aterm output (the Usage line with the
compile options)). I use .Xresources over here and it works fine.
Comment 2 chris 2005-02-07 07:51:23 EST
OK - I've done a bit more debugging, and found where the issue is. 
It's because the .spec file passes --enable-xgetdefault in to
%configure when it's building.  According to README.configure, that
enables resource checking via XGetDefault() instead of doing what the
manpage says it does (checking .Xdefaults/.Xresources directly).

I guess the simple solution is to get rid of the --enable-xgetdefault
in the .spec file, though that may cause problems for other people?
Comment 3 Andreas Bierfert 2005-02-08 07:26:26 EST
You are right, the .spec does pass --enable-xgetdefault to the
configure script. This does not mean however that
.Xresources/.Xdefaults is not read (see
http://xorg.freedesktop.org/X11R6.8.0/doc/manindex3.html). Besides its
working for a bunch of people I talked to. If you would be so kind and
attach a copy of the relevant options form your .Xdefaults/.Xresources
I could try to figure out whats not working for you...
Comment 4 Michael Schwendt 2005-02-08 10:48:25 EST
Such a change in the package would not be right. ~/.Xdefaults died
long ago in XFree86. Enabling a custom resource loader just to bring
it back to live, would be wrong.
Comment 5 Andreas Bierfert 2005-02-08 12:29:55 EST
Exactly what I think and why I enabled it in the first place...
Comment 6 chris 2005-02-10 05:27:56 EST
Sure, fair enough.  In that case, the manpage is misleading when it's
built with --enable-xgetdefault.

I'm probably doing something very stupid, in that case.  Further
debugging reveals that most of the Aterm* options in my ~/.Xresources
are being used correctly (*transparent, *saveLines, *fading, and
various others).  Sorry - my initial bug report was incorrect in that
regard.

However, one of them is not:

Aterm*foreground: powderblue

I always get a black foreground.  Changing it to Aterm.foreground
makes no difference.

But if I manually do an "xrdb .Xresources" and then fire up an aterm,
it's fine.  Alternatively, compiling with --enable-xgetdefault also
makes it read that resource correctly - though I agree with you that
that's the wrong solution ultimately.

Thanks for the help.  Sorry if this is something really silly.

chris% rpm -q aterm
aterm-0.4.2-5
chris% aterm -version
aterm version 0.4.2 from 06 September 01                             
          (background image,XPM,utmp,menubar,transparency,fading,NeXT
scrollbar,XGetDefaults)
Comment 7 Michael Schwendt 2005-02-10 10:44:50 EST
It's important to know what's in your ~/.Xresources file and what
"xrdb -query" reports after you have logged in, because your resources
are merged into the database. Loading just your file would remove the
other resources. I assume you have some desktop theme or
style-override activated, which activates other resources already,
e.g. *background and *foreground or XTerm resources you don't change
in your ~/.Xresources.
Comment 8 Michael Schwendt 2005-02-10 10:48:56 EST
Oh, and I think ~/.Xdefaults is only mentioned because of aterm's age
and because older implementations of X might have it. The manual could
be patched to drop that for Fedora.
Comment 9 Andreas Bierfert 2005-02-10 16:14:55 EST
Thanks for the insight, I will patch the man-page to not include .Xdefaults for
the next version. Currently 1.00.beta2 is out so maybe this can wait till final
is released. Don't think its a critical bug...
Comment 10 chris 2005-02-11 07:44:48 EST
OK.  Sorry for hassling you guys.  It was a bug in my understanding,
not in aterm.

Some startup script somewhere is setting:

*foreground:  #000000

I was under the impression that putting "Aterm*foreground" in my
.Xresources ought to override this, but it plainly isn't doing: if I
set "*foreground: yellow" I get yellow text in my aterm, etc., etc.,
irrespective of my "Aterm*foreground" setting.

However, setting aterm*foreground does override it.  I still don't
quite understand that, but that's my problem, not yours...

Sorry again for the hassle, and thanks for the help.

Note You need to log in before you can comment on or make changes to this bug.