Bug 147185 - IndexError: list index out of range
IndexError: list index out of range
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-04 13:42 EST by james
Modified: 2014-01-21 17:51 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-04 13:45:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description james 2005-02-04 13:42:52 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; X11; Linux i686) Opera 
7.54  [en]

Description of problem:
sudo yum -y install '*'

...
--> Running transaction check
--> Processing Conflict: sylpheed-claws conflicts sylpheed
--> Processing Conflict: oidentd conflicts pidentd
Traceback (most recent call last):
  File "/usr/bin/yum", line 7, in ?
    yummain.main(sys.argv[1:])
  File "/usr/share/yum-cli/yummain.py", line 104, in main
    (result, resultmsgs) = base.buildTransaction()
  File "/usr/lib/python2.3/site-packages/yum/__init__.py", line 174, 
in buildTransaction
  File "/usr/lib/python2.3/site-packages/yum/depsolve.py", line 190, 
in resolveDeps
  File "/usr/lib/python2.3/site-packages/yum/depsolve.py", line 494, 
in _processConflict
IndexError: list index out of range


Version-Release number of selected component (if applicable):
yum-2.1.12-1

How reproducible:
Always

Steps to Reproduce:
1.
2.
3.
    

Additional info:
Comment 1 Seth Vidal 2005-02-04 13:45:02 EST
fixed a while ago.

go update to 2.1.13 - currently in updates-testing and tell me if it
is fixed.
Comment 2 james 2005-02-05 01:11:04 EST
Ok, upgrade to yum-2.1.13-0.fc3 worked this time after modifying the
repository list.  "yum install *" fails with dependency errors, but
"yum update" worked fine this time.  Either way, there was no problem
with the "index out of range" error.  Thanks.

Note You need to log in before you can comment on or make changes to this bug.