Bug 1471857 - [downstream clone - 3.6.12] vdsm plugin - TypeError: add_copy_spec() takes exactly 2 arguments (3 given)
[downstream clone - 3.6.12] vdsm plugin - TypeError: add_copy_spec() takes ex...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: vdsm (Show other bugs)
3.6.10
Unspecified Unspecified
unspecified Severity urgent
: ovirt-3.6.12
: ---
Assigned To: Yaniv Bronhaim
Jiri Belka
: Regression, ZStream
Depends On: 1471663
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-17 10:34 EDT by Martin Perina
Modified: 2017-07-27 13:38 EDT (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1471663
Environment:
Last Closed: 2017-07-27 13:38:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 79542 ovirt-3.6 MERGED sos: fix addCopySpecLimit call 2017-07-18 06:50 EDT
Red Hat Product Errata RHBA-2017:1824 normal SHIPPED_LIVE vdsm 3.6.12 bug fix and enhancement update 2017-07-27 17:38:27 EDT

  None (edit)
Comment 1 Martin Perina 2017-07-17 17:54:45 EDT
Unfortunately every RHEL 7.x contains different SOS version and between those version backward compatibility is broken. So this fix needs to be verified with all RHEL versions which will be supported in 3.6.12
Comment 2 rhev-integ 2017-07-18 11:57:19 EDT
WARN: Bug status wasn't changed from MODIFIED to ON_QA due to the following reason:

[Found non-acked flags: '{'rhevm-3.6.z': '?'}', ]

For more info please contact: rhv-devops@redhat.comINFO: Bug status wasn't changed from MODIFIED to ON_QA due to the following reason:

[Found non-acked flags: '{'rhevm-3.6.z': '?'}', ]

For more info please contact: rhv-devops@redhat.com
Comment 4 Jiri Belka 2017-07-19 06:01:28 EDT
ok, vdsm-4.17.43-1.el7ev.noarch

redhat-release-server-7.3-7.el7.x86_64
sos-3.3-5.el7_3.noarch
vdsm-4.17.43-1.el7ev.noarch

# sosreport -o vdsm -v was OK

# tar tvJf /var/tmp/sosreport-dell-r210ii-03.example.com-20170719115200.tar.xz | egrep '(/var/log/vdsm|sos_commands)'
drwx------ root/root         0 2017-07-19 11:52 sosreport-dell-r210ii-03.example.com-20170719115200/sos_commands/
drwx------ root/root         0 2017-07-19 11:52 sosreport-dell-r210ii-03.example.com-20170719115200/sos_commands/vdsm/
-rw-r--r-- root/root      2343 2017-07-19 11:52 sosreport-dell-r210ii-03.example.com-20170719115200/sos_commands/vdsm/service_vdsmd_status
-rw-r--r-- root/root        87 2017-07-19 11:52 sosreport-dell-r210ii-03.example.com-20170719115200/sos_commands/vdsm/ls_-l_.var.log.core
-rw-r--r-- root/root        65 2017-07-19 11:52 sosreport-dell-r210ii-03.example.com-20170719115200/sos_commands/vdsm/ls_-ldZ_.etc.vdsm
-rw-r--r-- root/root      2532 2017-07-19 11:52 sosreport-dell-r210ii-03.example.com-20170719115200/sos_commands/vdsm/su_vdsm_-s_.bin.sh_-c_.usr.bin.tree_-l_.rhev.data-center
-rw-r--r-- root/root      3934 2017-07-19 11:52 sosreport-dell-r210ii-03.example.com-20170719115200/sos_commands/vdsm/su_vdsm_-s_.bin.sh_-c_.bin.ls_-lR_.rhev.data-center
-rw-r--r-- root/root       184 2017-07-19 11:52 sosreport-dell-r210ii-03.example.com-20170719115200/sos_commands/vdsm/lvm_vgs_-v_-o_tags
-rw-r--r-- root/root       184 2017-07-19 11:52 sosreport-dell-r210ii-03.example.com-20170719115200/sos_commands/vdsm/lvm_lvs_-v_-o_tags
-rw-r--r-- root/root       225 2017-07-19 11:52 sosreport-dell-r210ii-03.example.com-20170719115200/sos_commands/vdsm/lvm_pvs_-v_-o_all
-rw-r--r-- root/root      1331 2017-07-19 11:52 sosreport-dell-r210ii-03.example.com-20170719115200/sos_commands/vdsm/fdisk_-l
-rw-r--r-- root/root        27 2017-07-19 11:52 sosreport-dell-r210ii-03.example.com-20170719115200/sos_commands/vdsm/iscsiadm_-m_node
-rw-r--r-- root/root        30 2017-07-19 11:52 sosreport-dell-r210ii-03.example.com-20170719115200/sos_commands/vdsm/iscsiadm_-m_session
-rw-r--r-- root/root     11994 2017-07-19 11:52 sosreport-dell-r210ii-03.example.com-20170719115200/sos_commands/vdsm/vdsClient_-s_0_getVdsCapabilities
-rw-r--r-- root/root      5974 2017-07-19 11:52 sosreport-dell-r210ii-03.example.com-20170719115200/sos_commands/vdsm/vdsClient_-s_0_getVdsStats
-rw-r--r-- root/root         0 2017-07-19 11:52 sosreport-dell-r210ii-03.example.com-20170719115200/sos_commands/vdsm/vdsClient_-s_0_getAllVmStats
-rw-r--r-- root/root         0 2017-07-19 11:52 sosreport-dell-r210ii-03.example.com-20170719115200/sos_commands/vdsm/vdsClient_-s_0_list
-rw-r--r-- root/root         1 2017-07-19 11:52 sosreport-dell-r210ii-03.example.com-20170719115200/sos_commands/vdsm/vdsClient_-s_0_getVGList
-rw-r--r-- root/root         4 2017-07-19 11:52 sosreport-dell-r210ii-03.example.com-20170719115200/sos_commands/vdsm/vdsClient_-s_0_getDeviceList
-rw-r--r-- root/root         8 2017-07-19 11:52 sosreport-dell-r210ii-03.example.com-20170719115200/sos_commands/vdsm/vdsClient_-s_0_getAllTasksInfo
-rw-r--r-- root/root         8 2017-07-19 11:52 sosreport-dell-r210ii-03.example.com-20170719115200/sos_commands/vdsm/vdsClient_-s_0_getAllTasksStatuses
-rw-r--r-- root/root       788 2017-07-19 11:52 sosreport-dell-r210ii-03.example.com-20170719115200/sos_commands/vdsm/su_vdsm_-s_.usr.bin.python_.usr.share.vdsm.dumpStorageTable.pyc
drwxr-xr-x root/root         0 2017-07-18 14:08 sosreport-dell-r210ii-03.example.com-20170719115200/var/log/vdsm/
-rw-r--r-- root/root     49649 2017-07-19 11:52 sosreport-dell-r210ii-03.example.com-20170719115200/var/log/vdsm/supervdsm.log
-rw-r--r-- vdsm/kvm     639868 2017-07-19 04:00 sosreport-dell-r210ii-03.example.com-20170719115200/var/log/vdsm/vdsm.log.3.xz
-rw-r--r-- vdsm/kvm     592785 2017-07-19 11:52 sosreport-dell-r210ii-03.example.com-20170719115200/var/log/vdsm/mom.log
-rw-r--r-- vdsm/kvm     639992 2017-07-19 07:01 sosreport-dell-r210ii-03.example.com-20170719115200/var/log/vdsm/vdsm.log.2.xz
-rw-r--r-- root/root      1875 2017-07-18 13:41 sosreport-dell-r210ii-03.example.com-20170719115200/var/log/vdsm/upgrade.log
-rw-r--r-- vdsm/kvm     642076 2017-07-18 22:01 sosreport-dell-r210ii-03.example.com-20170719115200/var/log/vdsm/vdsm.log.5.xz
-rw-r--r-- vdsm/kvm     640248 2017-07-19 10:00 sosreport-dell-r210ii-03.example.com-20170719115200/var/log/vdsm/vdsm.log.1.xz
-rw-r--r-- vdsm/kvm       3797 2017-07-19 11:51 sosreport-dell-r210ii-03.example.com-20170719115200/var/log/vdsm/connectivity.log
-rw-r--r-- vdsm/kvm     661964 2017-07-18 19:01 sosreport-dell-r210ii-03.example.com-20170719115200/var/log/vdsm/vdsm.log.6.xz
-rw-r--r-- vdsm/kvm    9875108 2017-07-19 11:52 sosreport-dell-r210ii-03.example.com-20170719115200/var/log/vdsm/vdsm.log
-rw-r--r-- vdsm/kvm     640440 2017-07-19 01:01 sosreport-dell-r210ii-03.example.com-20170719115200/var/log/vdsm/vdsm.log.4.xz
Comment 5 Jiri Belka 2017-07-19 08:07:21 EDT
redhat-release-server-7.4-18.el7.x86_64
sos-3.4-5.el7.noarch
vdsm-4.17.43-1.el7ev.noarch

drwx------ root/root         0 2017-07-19 14:06 sosreport-dell-r210ii-03.rhev.lab.eng.brq.redhat.com-20170719140600/sos_commands/
drwx------ root/root         0 2017-07-19 14:06 sosreport-dell-r210ii-03.rhev.lab.eng.brq.redhat.com-20170719140600/sos_commands/vdsm/
-rw-r--r-- root/root      2294 2017-07-19 14:06 sosreport-dell-r210ii-03.rhev.lab.eng.brq.redhat.com-20170719140600/sos_commands/vdsm/service_vdsmd_status
-rw-r--r-- root/root         8 2017-07-19 14:06 sosreport-dell-r210ii-03.rhev.lab.eng.brq.redhat.com-20170719140600/sos_commands/vdsm/ls_-l_.var.log.core
-rw-r--r-- root/root        65 2017-07-19 14:06 sosreport-dell-r210ii-03.rhev.lab.eng.brq.redhat.com-20170719140600/sos_commands/vdsm/ls_-ldZ_.etc.vdsm
-rw-r--r-- root/root      2532 2017-07-19 14:06 sosreport-dell-r210ii-03.rhev.lab.eng.brq.redhat.com-20170719140600/sos_commands/vdsm/su_vdsm_-s_.bin.sh_-c_.usr.bin.tree_-l_.rhev.data-center
-rw-r--r-- root/root      3934 2017-07-19 14:06 sosreport-dell-r210ii-03.rhev.lab.eng.brq.redhat.com-20170719140600/sos_commands/vdsm/su_vdsm_-s_.bin.sh_-c_.bin.ls_-lR_.rhev.data-center
-rw-r--r-- root/root       184 2017-07-19 14:06 sosreport-dell-r210ii-03.rhev.lab.eng.brq.redhat.com-20170719140600/sos_commands/vdsm/lvm_vgs_-v_-o_tags
-rw-r--r-- root/root       184 2017-07-19 14:06 sosreport-dell-r210ii-03.rhev.lab.eng.brq.redhat.com-20170719140600/sos_commands/vdsm/lvm_lvs_-v_-o_tags
-rw-r--r-- root/root       225 2017-07-19 14:06 sosreport-dell-r210ii-03.rhev.lab.eng.brq.redhat.com-20170719140600/sos_commands/vdsm/lvm_pvs_-v_-o_all
-rw-r--r-- root/root      1331 2017-07-19 14:06 sosreport-dell-r210ii-03.rhev.lab.eng.brq.redhat.com-20170719140600/sos_commands/vdsm/fdisk_-l
-rw-r--r-- root/root        27 2017-07-19 14:06 sosreport-dell-r210ii-03.rhev.lab.eng.brq.redhat.com-20170719140600/sos_commands/vdsm/iscsiadm_-m_node
-rw-r--r-- root/root        30 2017-07-19 14:06 sosreport-dell-r210ii-03.rhev.lab.eng.brq.redhat.com-20170719140600/sos_commands/vdsm/iscsiadm_-m_session
-rw-r--r-- root/root     11680 2017-07-19 14:06 sosreport-dell-r210ii-03.rhev.lab.eng.brq.redhat.com-20170719140600/sos_commands/vdsm/vdsClient_-s_0_getVdsCapabilities
-rw-r--r-- root/root      5943 2017-07-19 14:06 sosreport-dell-r210ii-03.rhev.lab.eng.brq.redhat.com-20170719140600/sos_commands/vdsm/vdsClient_-s_0_getVdsStats
-rw-r--r-- root/root         0 2017-07-19 14:06 sosreport-dell-r210ii-03.rhev.lab.eng.brq.redhat.com-20170719140600/sos_commands/vdsm/vdsClient_-s_0_getAllVmStats
-rw-r--r-- root/root         0 2017-07-19 14:06 sosreport-dell-r210ii-03.rhev.lab.eng.brq.redhat.com-20170719140600/sos_commands/vdsm/vdsClient_-s_0_list
-rw-r--r-- root/root         1 2017-07-19 14:06 sosreport-dell-r210ii-03.rhev.lab.eng.brq.redhat.com-20170719140600/sos_commands/vdsm/vdsClient_-s_0_getVGList
-rw-r--r-- root/root         4 2017-07-19 14:06 sosreport-dell-r210ii-03.rhev.lab.eng.brq.redhat.com-20170719140600/sos_commands/vdsm/vdsClient_-s_0_getDeviceList
-rw-r--r-- root/root         8 2017-07-19 14:06 sosreport-dell-r210ii-03.rhev.lab.eng.brq.redhat.com-20170719140600/sos_commands/vdsm/vdsClient_-s_0_getAllTasksInfo
-rw-r--r-- root/root         8 2017-07-19 14:06 sosreport-dell-r210ii-03.rhev.lab.eng.brq.redhat.com-20170719140600/sos_commands/vdsm/vdsClient_-s_0_getAllTasksStatuses
-rw-r--r-- root/root       788 2017-07-19 14:06 sosreport-dell-r210ii-03.rhev.lab.eng.brq.redhat.com-20170719140600/sos_commands/vdsm/su_vdsm_-s_.usr.bin.python_.usr.share.vdsm.dumpStorageTable.pyc
drwxr-xr-x root/root         0 2017-07-19 14:01 sosreport-dell-r210ii-03.rhev.lab.eng.brq.redhat.com-20170719140600/var/log/vdsm/
-rw-r--r-- root/root     15023 2017-07-19 14:06 sosreport-dell-r210ii-03.rhev.lab.eng.brq.redhat.com-20170719140600/var/log/vdsm/supervdsm.log
-rw-r--r-- vdsm/kvm       3154 2017-07-19 14:06 sosreport-dell-r210ii-03.rhev.lab.eng.brq.redhat.com-20170719140600/var/log/vdsm/mom.log
-rw-r--r-- root/root      1875 2017-07-19 14:01 sosreport-dell-r210ii-03.rhev.lab.eng.brq.redhat.com-20170719140600/var/log/vdsm/upgrade.log
-rw-r--r-- vdsm/kvm        412 2017-07-19 14:03 sosreport-dell-r210ii-03.rhev.lab.eng.brq.redhat.com-20170719140600/var/log/vdsm/connectivity.log
-rw-r--r-- vdsm/kvm     215910 2017-07-19 14:06 sosreport-dell-r210ii-03.rhev.lab.eng.brq.redhat.com-20170719140600/var/log/vdsm/vdsm.log
Comment 7 errata-xmlrpc 2017-07-27 13:38:42 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1824

Note You need to log in before you can comment on or make changes to this bug.