This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1471874 - ksh kills itself with a signal if exit status is greater than 256
ksh kills itself with a signal if exit status is greater than 256
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: ksh (Show other bugs)
27
All All
medium Severity medium
: ---
: ---
Assigned To: Siteshwar Vashisht
Fedora Extras Quality Assurance
:
: 1469624 (view as bug list)
Depends On:
Blocks: 1460950
  Show dependency treegraph
 
Reported: 2017-07-17 10:52 EDT by Siteshwar Vashisht
Modified: 2017-08-21 07:31 EDT (History)
9 users (show)

See Also:
Fixed In Version: ksh-20120801-41.fc27
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1460950
Environment:
Last Closed: 2017-08-16 06:16:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Siteshwar Vashisht 2017-08-14 09:54:12 EDT
*** Bug 1469624 has been marked as a duplicate of this bug. ***
Comment 2 Jan Kurik 2017-08-15 03:43:39 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 27 development cycle.
Changing version to '27'.
Comment 3 Stephane Chazelas 2017-08-21 07:31:40 EDT
For the record, ksh93's behaviour is the behaviour that will likely be recommended by POSIX in the next major version of the standard:

http://www.austingroupbugs.net/view.php?id=51

Note You need to log in before you can comment on or make changes to this bug.