Bug 1471900 - Reporting an invalid MAC address when using DHCP
Reporting an invalid MAC address when using DHCP
Status: CLOSED DUPLICATE of bug 1154200
Product: Fedora
Classification: Fedora
Component: dhcp (Show other bugs)
26
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Pavel Zhukov
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-17 11:33 EDT by Scott
Modified: 2017-07-17 11:54 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-17 11:54:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Scott 2017-07-17 11:33:41 EDT
Description of problem:
On Fedora 26 when booting from a live cd or after installing, the MAC address that is being sent to the switch is invalid.  This is causing it to fail to receive a IP address since it does not match its reservation on the switch.

Version-Release number of selected component (if applicable):
Fedora 26

How reproducible:
When attempting to go online with a network switch that was configured with a DHCP reservation it is unable to get a reservation.  When investigating on the switch, the mac address this computer is reporting was: "96c5d3f100040994df4100b14585bv30a8637e91141e", obviously much longer than a valid mac address.  When I change to a network with an open scope it picks up an IP address immediately and works.

Steps to Reproduce:
1. Boot from fedora boot media
2. Attempt to go online using a DHCP reservation for the hardware MAC address


Actual results:
It fails to obtain an IP because the MAC address it reports is invalid.


Expected results:
It should report the hardware address correctly, and pick up an IP with a reservation.

Additional info:
Hardware is a Dell Optiplex 9020, BIOS A19.
On this identical hardware the network works fine with openSUSE.
"ifconfig -a" lists the correct mac address under eno1.
Attempting to manually set the same MAC with "ifconfig eno1 hw ether xx..." does not fix it.
Comment 1 Pavel Zhukov 2017-07-17 11:54:13 EDT
Hello,

Thank you for reporting the issue. 
Unfortunately it's a long story https://bugzilla.redhat.com/show_bug.cgi?id=1154200 . The client send option 21 (client-identifier. see RFC2131) and router uses it.
For installer there's RFE opened https://bugzilla.redhat.com/show_bug.cgi?id=1357469 to disable option 21 during the istallation.

*** This bug has been marked as a duplicate of bug 1154200 ***

Note You need to log in before you can comment on or make changes to this bug.