This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1471957 - When performing a rolling deployment of a large container on Online us-east-1, some router instances don't include endpoints
When performing a rolling deployment of a large container on Online us-east-1...
Status: CLOSED DUPLICATE of bug 1471899
Product: OpenShift Online
Classification: Red Hat
Component: Routing (Show other bugs)
3.x
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Ben Bennett
zhaozhanqi
: OnlineStarter
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-17 15:16 EDT by Clayton Coleman
Modified: 2017-08-31 13:33 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-31 13:33:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Clayton Coleman 2017-07-17 15:16:32 EDT
We have a prometheus instance in us-east-1 that, when updated, takes 20minutes to 3hours for each router instance to start including it again.  The endpoints are in place for the service (the new pod IP is in endpoints), but only some of the routers show up.

Project openshift-devops-monitor route prometheus
Comment 1 Clayton Coleman 2017-07-17 15:17:06 EDT
Only some of the router instances return the app - the others return a 503 for a very long time.  This is 3.6.126/8
Comment 2 Ben Bennett 2017-07-28 15:17:47 EDT
Please see the comment at https://bugzilla.redhat.com/show_bug.cgi?id=1471899#c2 for a way to tune things to work around this problem for the short term.
Comment 3 Ben Bennett 2017-08-31 13:33:20 EDT

*** This bug has been marked as a duplicate of bug 1471899 ***

Note You need to log in before you can comment on or make changes to this bug.