Bug 1471989 - Keys created by "create openstack key(s)" task are not readable by openstack users nova, cinder, etc. [NEEDINFO]
Keys created by "create openstack key(s)" task are not readable by openstack ...
Status: CLOSED ERRATA
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: Ceph-Ansible (Show other bugs)
2.4
Unspecified Unspecified
medium Severity medium
: rc
: 3.0
Assigned To: John Fulton
Yogev Rabl
: Triaged
Depends On:
Blocks: 1386911
  Show dependency treegraph
 
Reported: 2017-07-17 17:15 EDT by Giulio Fidente
Modified: 2018-06-26 19:46 EDT (History)
12 users (show)

See Also:
Fixed In Version: RHEL: ceph-ansible-2.3.0-0.1.rc4.el7cp Ubuntu: ceph-ansible_3.0.0~rc3-2redhat1
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-12-05 18:36:49 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
gfidente: needinfo? (yrabl)


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Github ceph/ceph-ansible/issues/1688 None None None 2017-07-17 17:15 EDT
Github ceph/ceph-ansible/pull/1696 None None None 2017-07-19 17:25 EDT
Red Hat Product Errata RHBA-2017:3387 normal SHIPPED_LIVE Red Hat Ceph Storage 3.0 bug fix and enhancement update 2017-12-05 22:03:45 EST

  None (edit)
Description Giulio Fidente 2017-07-17 17:15:57 EDT
Description of problem:
Keys created by ceph-ansible/roles/ceph-mon/tasks/openstack_config.yml are not readable by the OpenStack users who need to use them when using ceph-ansible to configure the keys for OpenStack clients that will run on the same servers.
Comment 2 John Fulton 2017-07-20 10:06:54 EDT
https://github.com/ceph/ceph-ansible/pull/1696 has merged
Comment 6 Harish NV Rao 2017-08-02 05:41:58 EDT
@Giulio, will you be verifying the fix for this defect when fixed? Please let me know.
Comment 7 Giulio Fidente 2017-08-07 05:57:36 EDT
Yes. Adding Yogev in CC responsible of QA/QE within Ceph Integration team, he can verify.
Comment 8 Harish NV Rao 2017-08-08 08:56:23 EDT
(In reply to Giulio Fidente from comment #7)
> Yes. Adding Yogev in CC responsible of QA/QE within Ceph Integration team,
> he can verify.


Thanks! I am providing the QA_ACK based on above information.
Comment 10 Giulio Fidente 2017-11-20 12:01:24 EST
Yogev, I think we can move this to VERIFIED?
Comment 13 errata-xmlrpc 2017-12-05 18:36:49 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:3387

Note You need to log in before you can comment on or make changes to this bug.