Bug 1471997 - freewrl gives SEGV immediately
freewrl gives SEGV immediately
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: freewrl (Show other bugs)
25
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tom "spot" Callaway
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-17 18:07 EDT by Paul DeStefano
Modified: 2017-09-11 20:22 EDT (History)
2 users (show)

See Also:
Fixed In Version: freewrl-3.0.0-5.20170729git4f920cb.fc26
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-09-11 20:22:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul DeStefano 2017-07-17 18:07:00 EDT
Description of problem:
freewrl in RPM doesn't see to run at all on F25.

Version-Release number of selected component (if applicable):
freewrl-3.0.0-1.fc25.x86_64

How reproducible:
Always since I installed it a few minutes ago.

Steps to Reproduce:
1. dnf install freewrl
2. freewrl

Actual results:
SEGV

Expected results:
no SEGV

Additional info:
I don't understand how FAF is supposed to work, but several crashes have already been reported, apparently.  Do I just give a link the FAF "problem" here?

https://retrace.fedoraproject.org/faf/problems/bthash/?bth=59e680440bbb96ec33c8a71d7db203a1a970d6ca
Comment 1 Paul DeStefano 2017-07-17 18:11:14 EDT
Sorry, I thought the ABRT bug report failed but I just lost track of the window.
Comment 2 Paul DeStefano 2017-07-17 19:04:17 EDT
Hmm, I tried it in a F26 VM and it doesn't crash using Mesa there.  I looked for a way to disable hardware accel but didn't find such an option.  Seems like a hardware accel problem.
Comment 3 Fedora Update System 2017-09-01 16:52:29 EDT
freewrl-3.0.0-5.20170729git4f920cb.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-36dfecae37
Comment 4 Fedora Update System 2017-09-03 01:24:25 EDT
freewrl-3.0.0-5.20170729git4f920cb.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-36dfecae37
Comment 5 Fedora Update System 2017-09-11 20:22:33 EDT
freewrl-3.0.0-5.20170729git4f920cb.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.