Bug 1472094 - Test script failing with brick multiplexing enabled
Test script failing with brick multiplexing enabled
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: disperse (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Sunil Kumar Acharya
:
Depends On:
Blocks: 1472794
  Show dependency treegraph
 
Reported: 2017-07-18 01:34 EDT by Sunil Kumar Acharya
Modified: 2017-09-05 13:37 EDT (History)
2 users (show)

See Also:
Fixed In Version: glusterfs-3.12.0
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
: 1472794 (view as bug list)
Environment:
Last Closed: 2017-08-21 04:21:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sunil Kumar Acharya 2017-07-18 01:34:10 EDT
Update the test script to avoid failures with brick multiplexing enabled.
Comment 1 Worker Ant 2017-07-18 02:10:52 EDT
REVIEW: https://review.gluster.org/17809 (cluster/ec: Test script failing with brick multiplexing enabled) posted (#1) for review on master by Sunil Kumar Acharya (sheggodu@redhat.com)
Comment 2 Worker Ant 2017-07-18 07:51:19 EDT
COMMIT: https://review.gluster.org/17809 committed in master by Pranith Kumar Karampuri (pkarampu@redhat.com) 
------
commit ae14513eb82929662b11e4c304877030a7d685cd
Author: Sunil Kumar Acharya <sheggodu@redhat.com>
Date:   Tue Jul 18 11:36:19 2017 +0530

    cluster/ec: Test script failing with brick multiplexing enabled
    
    Problem:
    Killing the bricks(using kill signal) in test scripts will
    result in test failures with brick multiplexing enabled.
    
    Solution:
    Updated the script to use kill_brick function to bring down
    the bricks.
    
    BUG: 1472094
    Change-Id: Ibbf1fdc1be660ad3cd93e95af2838c0aae0181af
    Signed-off-by: Sunil Kumar Acharya <sheggodu@redhat.com>
    Reviewed-on: https://review.gluster.org/17809
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
Comment 3 Shyamsundar 2017-09-05 13:37:29 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.12.0, please open a new bug report.

glusterfs-3.12.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/announce/2017-September/000082.html
[2] https://www.gluster.org/pipermail/gluster-users/

Note You need to log in before you can comment on or make changes to this bug.