Bug 1472131 - Guest OS will down when disk enable the IOMMU for Virtio
Guest OS will down when disk enable the IOMMU for Virtio
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: seabios (Show other bugs)
7.4
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: jason wang
FuXiangChun
: ZStream
: 1482387 (view as bug list)
Depends On: 1463163
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-18 02:51 EDT by Oneata Mircea Teodor
Modified: 2017-09-29 10:02 EDT (History)
16 users (show)

See Also:
Fixed In Version: seabios-1.10.2-4.el7
Doc Type: Bug Fix
Doc Text:
Previously, after enabling the Input/Output Memory Management Unit (IOMMU) for a Q35 machine type guest, the guest failed to boot and displayed a "No bootable device" error message. This update fixes the handling of IOMMU on Q35 guests, and the described problem no longer occurs.
Story Points: ---
Clone Of: 1463163
Environment:
Last Closed: 2017-09-05 07:23:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Oneata Mircea Teodor 2017-07-18 02:51:01 EDT
This bug has been copied from bug #1463163 and has been proposed to be backported to 7.4 z-stream (EUS).
Comment 2 Danilo Cesar de Paula 2017-07-26 17:15:00 EDT
Fix included in seabios-1.10.2-4.el7
Comment 4 FuXiangChun 2017-07-26 23:25:06 EDT
1)Reproduced bug with:
seabios-1.10.2-3.el7
3.10.0-693.el7.x86_64
qemu-kvm-rhev-2.9.0-16.el7_4.3.x86_64

cli:
/usr/libexec/qemu-kvm -M pc -cpu host -enable-kvm -m 2G -smp 4 -nodefconfig -rtc base=localtime,driftfix=slew -device virtio-scsi-pci,iommu_platform=on,id=scsi0,disable-legacy=on,disable-modern=off -drive file=/home/rhel74-64-virtio.qcow2,format=qcow2,if=none,id=drive-scsi0-0-0-0 -device scsi-hd,bus=scsi0.0,channel=0,scsi-id=0,lun=0,drive=drive-scsi0-0-0-0,id=scsi0-0-0-0,bootindex=1 -vnc :1 -monitor stdio

result:
Boot failed: could not read the boot disk

2)Verified bug with:
seabios-1.10.2-4.el7_4.x86_64
3.10.0-693.el7.x86_64
qemu-kvm-rhev-2.9.0-16.el7_4.3.x86_64

steps:
1. In host, add "iommu=pt intel_iommu=on" to kernel line
2. Add "intel_iommu=on" to kernel line of  q35/pc  guest
3. boot virtio-scsi with iommu_platform=on

result:
Guest works well

Additional
I tested device 'virtio-blk-pci' and machine type pc/q35 as well. Guest still works well.
Comment 5 FuXiangChun 2017-07-26 23:26:13 EDT
According to this comment4, set this bug as verified.
Comment 7 errata-xmlrpc 2017-09-05 07:23:01 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2567
Comment 8 Jaroslav Suchanek 2017-09-29 10:02:22 EDT
*** Bug 1482387 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.